base-files: Increase failsafe trigger wait time from 2 to 4 sec
authorHannu Nyman <hannu.nyman@iki.fi>
Wed, 16 Oct 2024 19:03:34 +0000 (22:03 +0300)
committerRobert Marko <robimarko@gmail.com>
Thu, 17 Oct 2024 16:15:05 +0000 (18:15 +0200)
Increase the failsafe waiting timeout period from 2 seconds
to 4 seconds.

Since commit 29207748b in 2015 we have had a rapid LED blinking
indication for the failsafe triggering period. But the really short
timeout of 2 seconds requires snappy reaction time from the user to
notice the LED blinking and to push button inside the short window.

Relax the timeout to 4 seconds, which more easily allows to notice
the change in LED blinking and push a button.

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Link: https://github.com/openwrt/openwrt/pull/11852
Signed-off-by: Robert Marko <robimarko@gmail.com>
package/base-files/Makefile
package/base-files/image-config.in

index 313bf377b492fead68716f24564e361ae9bd82c4..4da50a27362dcea82c0af943c7b53a6123ed1f7e 100644 (file)
@@ -77,7 +77,7 @@ endef
 define ImageConfigOptions
        mkdir -p $(1)/lib/preinit
        echo 'pi_suppress_stderr="$(CONFIG_TARGET_PREINIT_SUPPRESS_STDERR)"' >$(1)/lib/preinit/00_preinit.conf
-       echo 'fs_failsafe_wait_timeout=$(if $(CONFIG_TARGET_PREINIT_TIMEOUT),$(CONFIG_TARGET_PREINIT_TIMEOUT),2)' >>$(1)/lib/preinit/00_preinit.conf
+       echo 'fs_failsafe_wait_timeout=$(if $(CONFIG_TARGET_PREINIT_TIMEOUT),$(CONFIG_TARGET_PREINIT_TIMEOUT),4)' >>$(1)/lib/preinit/00_preinit.conf
        echo 'pi_init_path="$(TARGET_INIT_PATH)"' >>$(1)/lib/preinit/00_preinit.conf
        echo 'pi_init_env=$(if $(CONFIG_TARGET_INIT_ENV),$(CONFIG_TARGET_INIT_ENV),"")' >>$(1)/lib/preinit/00_preinit.conf
        echo 'pi_init_cmd=$(if $(CONFIG_TARGET_INIT_CMD),$(CONFIG_TARGET_INIT_CMD),"/sbin/init")' >>$(1)/lib/preinit/00_preinit.conf
index 2de2130b8490d9f18fa0b0189fa1ed7432e9528a..dee06e9b864b789084d11555f286d9a12f4e4109 100644 (file)
@@ -44,7 +44,7 @@ config TARGET_PREINIT_DISABLE_FAILSAFE
 config TARGET_PREINIT_TIMEOUT
        int
        prompt "Failsafe/Debug wait timeout" if PREINITOPT
-       default 2
+       default 4
        help
                How long to wait for failsafe mode to be entered or for
                a debug option to be pressed before continuing with a