compat-drivers: add CONFIG_MWIFIEX_USB in config.mk
authorHauke Mehrtens <hauke@hauke-m.de>
Mon, 5 Nov 2012 23:11:54 +0000 (00:11 +0100)
committerLuis R. Rodriguez <mcgrof@do-not-panic.com>
Fri, 16 Nov 2012 05:34:08 +0000 (21:34 -0800)
The driver at least compiles with all supported kernel versions.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Signed-off-by: Luis R. Rodriguez <mcgrof@do-not-panic.com>
config.mk
patches/network/06-header-changes.patch

index 985fb6a6da4268dea525e21194bf4fe4648a2006..dde855439c6641e2c7db314df4e4ac97dba6b9a2 100644 (file)
--- a/config.mk
+++ b/config.mk
@@ -558,6 +558,8 @@ export CONFIG_BT_ATH3K=m
 
 export CONFIG_RTL8192CU=m
 
+export CONFIG_MWIFIEX_USB=m
+
 endif #CONFIG_USB end of USB driver list
 
 ifdef CONFIG_SPI_MASTER
index d77e5fb22750a6a4af784b6a67867c4f92cce968..cd587cd1dbb216a75a1c551ba90af958f1cf4bc5 100644 (file)
@@ -115,3 +115,13 @@ cases.
  
  #include "core.h"
  #include "cfg80211.h"
+--- a/drivers/net/wireless/mwifiex/usb.c
++++ b/drivers/net/wireless/mwifiex/usb.c
+@@ -19,6 +19,7 @@
+ #include "main.h"
+ #include "usb.h"
++#include <linux/usb/audio.h>
+ #define USB_VERSION   "1.0"