projects
/
openwrt
/
staging
/
blogic.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
05c3eeb
)
USB: tools: Add a Makefile
author
Davidlohr Bueso
<dave@gnu.org>
Sun, 6 Feb 2011 17:13:37 +0000
(14:13 -0300)
committer
Greg Kroah-Hartman
<gregkh@suse.de>
Thu, 17 Feb 2011 18:43:03 +0000
(10:43 -0800)
Build USB tools easier.
Signed-off-by: Davidlohr Bueso <dave@gnu.org>
Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
tools/usb/Makefile
[new file with mode: 0644]
patch
|
blob
diff --git a/tools/usb/Makefile
b/tools/usb/Makefile
new file mode 100644
(file)
index 0000000..
8b704af
--- /dev/null
+++ b/
tools/usb/Makefile
@@ -0,0
+1,13
@@
+# Makefile for USB tools
+
+CC = $(CROSS_COMPILE)gcc
+PTHREAD_LIBS = -lpthread
+WARNINGS = -Wall -Wextra
+CFLAGS = $(WARNINGS) -g $(PTHREAD_LIBS)
+
+all: testusb ffs-test
+%: %.c
+ $(CC) $(CFLAGS) -o $@ $^
+
+clean:
+ $(RM) testusb ffs-test