projects
/
openwrt
/
staging
/
adrian.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
2b318ce
)
add extra rebuild check for development libraries
author
Felix Fietkau
<nbd@openwrt.org>
Thu, 7 Sep 2006 12:48:22 +0000
(12:48 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Thu, 7 Sep 2006 12:48:22 +0000
(12:48 +0000)
SVN-Revision: 4770
openwrt/include/package.mk
patch
|
blob
|
history
diff --git
a/openwrt/include/package.mk
b/openwrt/include/package.mk
index 515698d691d3b7064617aa168cd9bba00aa7b7f8..42ffcfbb3ce33b2f9141ac056f6427d64572d5bb 100644
(file)
--- a/
openwrt/include/package.mk
+++ b/
openwrt/include/package.mk
@@
-39,6
+39,10
@@
define Build/DefaultTargets
touch $$@
ifdef Build/InstallDev
+ ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install $(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed $(PKG_BUILD_DIR)),$(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed)
+ $(PKG_BUILD_DIR)/.built: package-rebuild
+ endif
+
$(STAGING_DIR)/stampfiles/.$(PKG_NAME)-installed: $(PKG_BUILD_DIR)/.built
mkdir -p $(STAGING_DIR)/stampfiles
$(call Build/InstallDev)