projects
/
openwrt
/
staging
/
jow.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
7ebcf2f
)
sunxi: update the 6.6 DTS_DIR hack
author
Zoltan HERPAI
<wigyori@uid0.hu>
Fri, 26 Apr 2024 09:06:17 +0000
(11:06 +0200)
committer
Zoltan HERPAI
<wigyori@uid0.hu>
Fri, 26 Apr 2024 09:07:43 +0000
(11:07 +0200)
Update and simplify the 6.1 vs. 6.6 DTS_DIR hack until 6.1 support is gone.
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
target/linux/sunxi/image/Makefile
patch
|
blob
|
history
diff --git
a/target/linux/sunxi/image/Makefile
b/target/linux/sunxi/image/Makefile
index d462880e904e6579338a375ada910433ffe8b9bf..fc1359d173cf1281c97fc58161d375d69d760880 100644
(file)
--- a/
target/linux/sunxi/image/Makefile
+++ b/
target/linux/sunxi/image/Makefile
@@
-34,9
+34,7
@@
define Device/Default
KERNEL := kernel-bin | uImage none
IMAGES := sdcard.img.gz
IMAGE/sdcard.img.gz := sunxi-sdcard | append-metadata | gzip
-ifneq ($(LINUX_6_1),)
- SUNXI_DTS_DIR :=
-else
+ifdef CONFIG_LINUX_6_6
SUNXI_DTS_DIR :=allwinner/
endif
SUNXI_DTS = $$(SUNXI_DTS_DIR)$$(SOC)-$(lastword $(subst _, ,$(1)))