ath79: image: append metadata to routerstations and ja76pf2 images
authorTomasz Maciej Nowak <tomek_n@o2.pl>
Fri, 23 Aug 2019 13:50:49 +0000 (15:50 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Sun, 29 Sep 2019 09:31:05 +0000 (11:31 +0200)
This target enforces metadata check so add the necessary information. It
was previously removed because md5 sum check. When using these sysupgrade
images on ar71xx target the check would complain about them not matching.

Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
(cherry picked from commit 077d06a1a5a23caae4d0c53afb60913955d2a3ea)

target/linux/ath79/image/generic-ubnt.mk
target/linux/ath79/image/generic.mk

index b189d667707859d3994b853d6366135e227c544a..f9f74d0f51986bdf9b2f82c982a4b53e8ae5feb6 100644 (file)
@@ -205,7 +205,7 @@ define Device/ubnt_routerstation_common
   IMAGE_SIZE := 16128k
   IMAGES += factory.bin
   IMAGE/factory.bin := append-rootfs | pad-rootfs | mkubntimage | check-size $$$$(IMAGE_SIZE)
-  IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | combined-image | check-size $$$$(IMAGE_SIZE)
+  IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | combined-image | append-metadata | check-size $$$$(IMAGE_SIZE)
 #  IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | sysupgrade-tar rootfs=$$$$@ | append-metadata
   KERNEL := kernel-bin | append-dtb | lzma | pad-to $$(BLOCKSIZE)
   KERNEL_INITRAMFS := kernel-bin | append-dtb
index 4bfdd69d6d98f9d340f1e3bf2c7f1cd466420a92..a2b82cbf7fe909d4c73e9a34cd4b71fbbef2809e 100644 (file)
@@ -474,7 +474,7 @@ define Device/jjplus_ja76pf2
   ATH_SOC := ar7161
   DEVICE_TITLE := jjPlus JA76PF2
   DEVICE_PACKAGES += -kmod-ath9k -swconfig -wpad-mini -uboot-envtools fconfig
-  IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | combined-image | check-size $$$$(IMAGE_SIZE)
+  IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | combined-image | append-metadata | check-size $$$$(IMAGE_SIZE)
 #  IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE) | sysupgrade-tar rootfs=$$$$@ | append-metadata
   KERNEL := kernel-bin | append-dtb | lzma | pad-to $$(BLOCKSIZE)
   KERNEL_INITRAMFS := kernel-bin | append-dtb