compat-wireless: run ./scripts/compat_firmware_install
authorLuis R. Rodriguez <lrodriguez@atheros.com>
Mon, 24 May 2010 16:57:24 +0000 (09:57 -0700)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Mon, 24 May 2010 16:57:24 +0000 (09:57 -0700)
We were not running this before so users of compat-wireless would
not get the compat_firmware stuff properly installed. Since the
compat_firmware_*() API is used for *all* compat-wireless drivers
this should mean loading of the firmware would have failed for
all those requiring firmware.

Signed-off-by: Luis R. Rodriguez <lrodriguez@atheros.com>
Makefile

index e2041123d2d8e2eb37e4be5421f41aa24eca648a..0cf16225767e21432dac561c79165780e61b153d 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -131,6 +131,7 @@ install: uninstall install-modules install-scripts
 install-modules: modules
        $(MAKE) -C $(KLIB_BUILD) M=$(PWD) $(KMODDIR_ARG) $(KMODPATH_ARG) \
                modules_install
+       @./scripts/compat_firmware_install
        @./scripts/update-initramfs
 
 install-scripts: