gnutls: Allow gnutls to be compiled using nettle-mini.
authorFlorian Fainelli <florian@openwrt.org>
Thu, 8 May 2014 00:57:40 +0000 (00:57 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 8 May 2014 00:57:40 +0000 (00:57 +0000)
Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 40723

libs/gnutls/Makefile

index c2a010a6568a03dc957cbf9b2429b7896383dd2b..997532bdfc66cce417afa44b7927d565f6236629 100644 (file)
@@ -75,7 +75,7 @@ endef
 define Package/libgnutls
 $(call Package/gnutls/Default)
   TITLE+= (library)
-  DEPENDS+= +libnettle
+  DEPENDS+= +libnettle +!LIBNETTLE_MINI:libgmp
 endef
 
 define Package/libgnutls/description
@@ -110,6 +110,10 @@ CONFIGURE_ARGS+= \
        --disable-crywrap \
        --without-p11-kit
 
+ifeq ($(CONFIG_LIBNETTLE_MINI),y)
+CONFIGURE_ARGS += --with-nettle-mini
+endif
+
 ifneq ($(CONFIG_GNUTLS_DTLS_SRTP),y)
 CONFIGURE_ARGS += --disable-dtls-srtp-support
 endif