projects
/
openwrt
/
staging
/
hauke.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
86bd886
)
ramips: fix AR670W partition alignment
author
Claudio Leite
<leitec@gmail.com>
Sun, 5 Feb 2017 08:59:45 +0000
(
03:59
-0500)
committer
John Crispin
<john@phrozen.org>
Wed, 8 Feb 2017 05:16:53 +0000
(06:16 +0100)
mtdsplit_lzma requires that the rootfs be aligned to a block boundary.
Pad the kernel partition to make this so.
Signed-off-by: Claudio Leite <leitec@gmail.com>
target/linux/ramips/image/rt288x.mk
patch
|
blob
|
history
diff --git
a/target/linux/ramips/image/rt288x.mk
b/target/linux/ramips/image/rt288x.mk
index f22182fbf298fcb20fab03e683d0e72dacffe284..93cdda519cccb9900aefec1aa6897db7365a3e04 100644
(file)
--- a/
target/linux/ramips/image/rt288x.mk
+++ b/
target/linux/ramips/image/rt288x.mk
@@
-14,7
+14,7
@@
define Device/ar670w
BLOCKSIZE := 64k
DEVICE_TITLE := Airlink AR670W
IMAGE_SIZE := $(ralink_default_fw_size_4M)
- KERNEL := $(KERNEL_DTB)
+ KERNEL := $(KERNEL_DTB)
| pad-to $$(BLOCKSIZE)
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
wrg-header wrgn16a_airlink_ar670w