Makefile: add savedefconfig target.
authorAvery Pennarun <apenwarr@gmail.com>
Wed, 30 Apr 2014 01:29:06 +0000 (21:29 -0400)
committerLuis R. Rodriguez <mcgrof@do-not-panic.com>
Fri, 2 May 2014 01:44:14 +0000 (18:44 -0700)
This writes a file called 'defconfig' which contains only the deltas from
the default configuration.  It's suitable for use as an input defconfig file
for later builds.

Signed-off-by: Avery Pennarun <apenwarr@gmail.com>
Signed-off-by: Luis R. Rodriguez <mcgrof@do-not-panic.com>
backport/Makefile.real

index b010dd7808da82bf20e7d3deaddf5ef02c8bc92f..f60d5ca211a5ef2e769e9f7e9d95a20b0cbded5c 100644 (file)
@@ -32,6 +32,11 @@ usedefconfig:
        @$(MAKE) -C kconf conf
        @./kconf/conf --defconfig=defconfig Kconfig
 
+.PHONY: savedefconfig
+savedefconfig:
+       @$(MAKE) -C kconf conf
+       @./kconf/conf --savedefconfig=defconfig Kconfig
+
 defconfig-%::
        @$(MAKE) -C kconf conf
        @./kconf/conf --defconfig=defconfigs/$(@:defconfig-%=%) Kconfig