projects
/
openwrt
/
staging
/
adrian.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
c51cbc4
)
Allow extracting in non-standard PKG_BUILD_DIR
author
Nicolas Thill
<nico@openwrt.org>
Fri, 13 May 2005 01:45:56 +0000
(
01:45
+0000)
committer
Nicolas Thill
<nico@openwrt.org>
Fri, 13 May 2005 01:45:56 +0000
(
01:45
+0000)
SVN-Revision: 865
openwrt/package/rules.mk
patch
|
blob
|
history
diff --git
a/openwrt/package/rules.mk
b/openwrt/package/rules.mk
index 76322e1e0fd993c1eb67c9365b5f1ec7508813e5..51be45814d09142f54034f3ffbc00d90b5ac4824 100644
(file)
--- a/
openwrt/package/rules.mk
+++ b/
openwrt/package/rules.mk
@@
-35,7
+35,8
@@
endif
ifneq ($(strip $(PKG_CAT)),)
$(PKG_BUILD_DIR)/.prepared: $(DL_DIR)/$(PKG_SOURCE)
rm -rf $(PKG_BUILD_DIR)
- $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+ mkdir -p $(PKG_BUILD_DIR)
+ $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(PKG_BUILD_DIR)/.. $(TAR_OPTIONS) -
if [ -d ./patches ]; then \
$(PATCH) $(PKG_BUILD_DIR) ./patches ; \
fi