ramips: mt7621: Edgerouter-X drop factory image
authorTim Lunn <tim@feathertop.org>
Fri, 19 Apr 2024 12:16:11 +0000 (22:16 +1000)
committerPetr Štetiar <ynezz@true.cz>
Fri, 8 Nov 2024 12:37:12 +0000 (12:37 +0000)
Edgerouter-X factory images have not built automatically since 19.x due
to images being over 3MB. While it was possible to build custom images
with very stripped down config, this is no longer possible with the size
increases of linux 6.1 and 6.6.

Drop code for generation of factory images, if some dev later wishes to
try custom images they can revert this commit.

Signed-off-by: Tim Lunn <tim@feathertop.org>
Link: https://github.com/openwrt/openwrt/pull/15194
Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/linux/ramips/image/mt7621.mk

index b9692c5f3ad94f46aabad52128e9361538b3af29..bebe40c2161838078c810ed7751b21d1b2f5eb50 100644 (file)
@@ -229,30 +229,6 @@ define Build/belkin-header
        mv $@.new $@
 endef
 
-define Build/ubnt-erx-factory-image
-       if [ -e $(KDIR)/tmp/$(KERNEL_INITRAMFS_IMAGE) -a "$$(stat -c%s $@)" -lt "$(KERNEL_SIZE)" ]; then \
-               echo '21001:7' > $(1).compat; \
-               $(TAR) -cf $(1) --transform='s/^.*/compat/' $(1).compat; \
-               \
-               $(TAR) -rf $(1) --transform='s/^.*/vmlinux.tmp/' $(KDIR)/tmp/$(KERNEL_INITRAMFS_IMAGE); \
-               $(MKHASH) md5 $(KDIR)/tmp/$(KERNEL_INITRAMFS_IMAGE) > $(1).md5; \
-               $(TAR) -rf $(1) --transform='s/^.*/vmlinux.tmp.md5/' $(1).md5; \
-               \
-               echo "dummy" > $(1).rootfs; \
-               $(TAR) -rf $(1) --transform='s/^.*/squashfs.tmp/' $(1).rootfs; \
-               \
-               $(MKHASH) md5 $(1).rootfs > $(1).md5; \
-               $(TAR) -rf $(1) --transform='s/^.*/squashfs.tmp.md5/' $(1).md5; \
-               \
-               echo '$(BOARD) $(VERSION_CODE) $(VERSION_NUMBER)' > $(1).version; \
-               $(TAR) -rf $(1) --transform='s/^.*/version.tmp/' $(1).version; \
-               \
-               $(CP) $(1) $(BIN_DIR)/; \
-       else \
-               echo "WARNING: initramfs kernel image too big, cannot generate factory image (actual $$(stat -c%s $@); max $(KERNEL_SIZE))" >&2; \
-       fi
-endef
-
 define Build/zytrx-header
        $(eval board=$(word 1,$(1)))
        $(eval version=$(word 2,$(1)))
@@ -2861,8 +2837,6 @@ define Device/ubnt_edgerouter_common
   IMAGE_SIZE := 256768k
   FILESYSTEMS := squashfs
   KERNEL_SIZE := 6144k
-  KERNEL_INITRAMFS := $$(KERNEL) | \
-       ubnt-erx-factory-image $(KDIR)/tmp/$$(KERNEL_INITRAMFS_PREFIX)-factory.tar
   IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
   DEVICE_PACKAGES += -wpad-basic-mbedtls -uboot-envtools
   DEVICE_COMPAT_VERSION := 2.0