ramips: mt7621: use lzma-loader for Sercomm NA502s
authorAndreas Böhler <dev@aboehler.at>
Sun, 15 Sep 2024 21:35:08 +0000 (23:35 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 18 Sep 2024 21:04:37 +0000 (23:04 +0200)
This fixes a well-known "LZMA ERROR 1" error on Sercomm NA502s, reported
on the OpneWrt forum [0].

[0] https://forum.openwrt.org/t/206640

Signed-off-by: Andreas Böhler <dev@aboehler.at>
(cherry picked from commit 6d89aa29878a93c744e8c752a68bc05d41252cfc)
Link: https://github.com/openwrt/openwrt/pull/16412
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/ramips/image/mt7621.mk

index 504c56e2b875c584cee3c15631e00aa75cea56a3..a5dc68c84d66ee02e337c0697aa2bab8379cc47f 100644 (file)
@@ -2068,6 +2068,7 @@ TARGET_DEVICES += sercomm_na502
 
 define Device/sercomm_na502s
   $(Device/nand)
+  $(Device/uimage-lzma-loader)
   IMAGE_SIZE := 20971520
   DEVICE_VENDOR := SERCOMM
   DEVICE_MODEL := NA502S