projects
/
openwrt
/
staging
/
nbd.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
290534c
)
linux/crypto: Add echainiv module provided by 4.4 kernels
author
John Crispin
<john@openwrt.org>
Fri, 12 Feb 2016 08:31:54 +0000
(08:31 +0000)
committer
John Crispin
<john@openwrt.org>
Fri, 12 Feb 2016 08:31:54 +0000
(08:31 +0000)
This module is needed for IPsec ESP support, i.e..
Signed-off-by: André Valentin <avalentin@marcant.net>
SVN-Revision: 48714
package/kernel/linux/modules/crypto.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/crypto.mk
b/package/kernel/linux/modules/crypto.mk
index a47a1b678a3d27e3911386513f066d500a7d5bcc..dddddccbdd425df96038321b7c1b60aafd8d6537 100644
(file)
--- a/
package/kernel/linux/modules/crypto.mk
+++ b/
package/kernel/linux/modules/crypto.mk
@@
-133,6
+133,18
@@
endef
$(eval $(call KernelPackage,crypto-iv))
+
+define KernelPackage/crypto-echainiv
+ TITLE:=Encrypted Chain IV Generator
+ KCONFIG:=CONFIG_CRYPTO_ECHAINIV
+ FILES:=$(LINUX_DIR)/crypto/echainiv.ko
+ AUTOLOAD:=$(call AutoLoad,09,echainiv)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-echainiv))
+
+
define KernelPackage/crypto-seqiv
TITLE:=CryptoAPI Sequence Number IV Generator
DEPENDS:=+kmod-crypto-aead +kmod-crypto-rng