projects
/
openwrt
/
staging
/
lynxis.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
a04bffe
)
trusted-firmware-a.mk: pass package version as version identifier
author
Andre Heider
<a.heider@gmail.com>
Fri, 22 Jan 2021 13:44:08 +0000
(14:44 +0100)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Sat, 30 Jan 2021 13:46:32 +0000
(14:46 +0100)
Upon boot it now prints:
NOTICE: BL1: v2.4(release):OpenWRT v2.4-1 (espressobin-v3-v5-1gb-2cs) (Marvell-devel-18.12.0)
Signed-off-by: Andre Heider <a.heider@gmail.com>
include/trusted-firmware-a.mk
patch
|
blob
|
history
diff --git
a/include/trusted-firmware-a.mk
b/include/trusted-firmware-a.mk
index b89014b249a4ae2c0c1c3838f84216860300b6e4..ec3e4f4e6b56f9b55110bf1eefb8413e01ae3a78 100644
(file)
--- a/
include/trusted-firmware-a.mk
+++ b/
include/trusted-firmware-a.mk
@@
-73,6
+73,7
@@
define Build/Compile/Trusted-Firmware-A
CROSS_COMPILE=$(TARGET_CROSS) \
OPENSSL_DIR=$(STAGING_DIR_HOST) \
PLAT=$(PLAT) \
+ BUILD_STRING="OpenWRT v$(PKG_VERSION)-$(PKG_RELEASE) ($(VARIANT))" \
$(TFA_MAKE_FLAGS)
endef