build: fix including busybox, procd and apk/opkg in imagebuilder
authorFelix Fietkau <nbd@nbd.name>
Wed, 13 Nov 2024 06:04:31 +0000 (07:04 +0100)
committerFelix Fietkau <nbd@nbd.name>
Wed, 13 Nov 2024 06:12:21 +0000 (07:12 +0100)
Since the image builder pulls package lists from metadata directly,
add procd and busybox as depdendencies to base-files.
As for the package manager itself, since it can be disabled it needs
to be added directly in the image builder makefile

Fixes: 44598c233dd9 ("build: remove broken dependency of metadata on toplevel .config variables")
Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/base-files/Makefile
package/system/procd/Makefile
package/utils/busybox/Makefile
target/imagebuilder/files/Makefile

index 4bcb4882d733c4a0164f80d2cee5497c57569ebc..7ac4ea557f9f10d4d13407b5e8c5cb69a40df304 100644 (file)
@@ -39,7 +39,11 @@ endif
 define Package/base-files
   SECTION:=base
   CATEGORY:=Base system
-  DEPENDS:=+netifd +libc +jsonfilter +SIGNED_PACKAGES:usign +SIGNED_PACKAGES:openwrt-keyring +NAND_SUPPORT:ubi-utils +fstools +fwtool
+  DEPENDS:= \
+       +netifd +libc +jsonfilter +SIGNED_PACKAGES:usign +SIGNED_PACKAGES:openwrt-keyring \
+       +NAND_SUPPORT:ubi-utils +fstools +fwtool \
+       +SELINUX:procd-selinux +!SELINUX:procd +SECCOMP:procd-seccomp \
+       +SELINUX:busybox-selinux +!SELINUX:busybox
   TITLE:=Base filesystem for OpenWrt
   URL:=http://openwrt.org/
   VERSION:=$(PKG_RELEASE)~$(lastword $(subst -, ,$(REVISION)))
index 9ff6fb80f7c949c5e03073316a01a66be7aa068f..86de4babfdfaff82c88eca90d516d80a256cbe34 100644 (file)
@@ -50,7 +50,6 @@ define Package/procd
   $(call Package/procd/Default)
   VARIANT:=default
   CONFLICTS:=procd-selinux
-  DEFAULT:=y if !SELINUX
 endef
 
 define Package/procd-selinux
@@ -59,7 +58,6 @@ define Package/procd-selinux
   TITLE += with SELinux support
   PROVIDES:=procd
   VARIANT:=selinux
-  DEFAULT:=y if SELINUX
 endef
 
 define Package/procd-ujail
@@ -75,7 +73,6 @@ define Package/procd-seccomp
   CATEGORY:=Base system
   DEPENDS:=@SECCOMP +libubox +libblobmsg-json
   TITLE:=OpenWrt process seccomp helper + utrace
-  DEFAULT:=y if SECCOMP
 endef
 
 define Package/uxc
index 7b591db71679c7f127b042b8e589491a40d58d7b..4ef470df75589060d9871dc8c5c96a0d8fb70f53 100644 (file)
@@ -56,7 +56,6 @@ define Package/busybox
   $(call Package/busybox/Default)
   CONFLICTS:=busybox-selinux
   VARIANT:=default
-  DEFAULT:=y if !SELINUX
 endef
 
 define Package/busybox-selinux
@@ -65,7 +64,6 @@ define Package/busybox-selinux
   DEPENDS += +libselinux
   VARIANT:=selinux
   PROVIDES:=busybox
-  DEFAULT:=y if SELINUX
 endef
 
 define Package/busybox/description
index 72b36b0862389d225e1fe621c4f15a38f43d7dee..c92ab7430663b71cfa6626caa1576ce9fe17e8f5 100644 (file)
@@ -138,6 +138,11 @@ _call_info: FORCE
        echo 'Available Profiles:'
        echo; $(PROFILE_LIST)
 
+ifneq ($(CONFIG_USE_APK),)
+  DEFAULT_PACKAGES += apk-mbedtls
+else
+  DEFAULT_PACKAGES += opkg
+endif
 BUILD_PACKAGES:=$(sort $(DEFAULT_PACKAGES) $($(USER_PROFILE)_PACKAGES) kernel)
 # "-pkgname" in the package list means remove "pkgname" from the package list
 BUILD_PACKAGES:=$(filter-out $(filter -%,$(BUILD_PACKAGES)) $(patsubst -%,%,$(filter -%,$(BUILD_PACKAGES))),$(BUILD_PACKAGES))