[packages] collectd: lazily evaluate CONFIGURE_PLUGIN (thanks nbd) (#6447), update...
authorStephen Walker <stephendwalker@gmail.com>
Fri, 15 Jan 2010 21:58:28 +0000 (21:58 +0000)
committerStephen Walker <stephendwalker@gmail.com>
Fri, 15 Jan 2010 21:58:28 +0000 (21:58 +0000)
SVN-Revision: 19154

utils/collectd/Makefile
utils/collectd/files/collectd.conf
utils/collectd/patches/100-rrdtool-add-rrasingle-option.patch

index c6add0c028d1d6c5bb65620132e6f813a9f9e4e7..379f9d3a48654f75dae31d9ede6cd19851970550 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=collectd
-PKG_VERSION:=4.9.0
+PKG_VERSION:=4.9.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://collectd.org/files/
-PKG_MD5SUM:=5b2e5f57716f2485a3b4eb57774a3818
+PKG_MD5SUM:=5753496651c8c84afaea1fe290876bfc
 
 PKG_FIXUP:=libtool
+PKG_INSTALL:=1
 
 COLLECTD_PLUGINS_DISABLED:= \
        apple_sensors \
@@ -147,7 +148,7 @@ CONFIGURE_VARS+= \
        LDFLAGS="$$$$LDFLAGS -lm -lz" \
        KERNEL_DIR="$(LINUX_DIR)" \
 
-CONFIGURE_PLUGIN:= \
+CONFIGURE_PLUGIN= \
        $(foreach m, $(1), \
                $(if $(CONFIG_PACKAGE_collectd-mod-$(m)),--enable-$(m),--disable-$(m)) \
        )
@@ -177,10 +178,6 @@ ifneq ($(CONFIG_PACKAGE_collectd-mod-rrdtool),)
   CONFIGURE_ARGS+= --with-librrd="$(STAGING_DIR)/usr/lib/rrdtool-1.0"
 endif
 
-MAKE_FLAGS += \
-       DESTDIR="$(PKG_INSTALL_DIR)" \
-       all install
-
 define Package/collectd/conffiles
 /etc/collectd.conf
 endef
index 15a7c18c08f3ea84e4f84d0264e63d9263122549..2ef78fe7ff40a6994c7addc9b7f4e9031e54b75c 100644 (file)
@@ -71,7 +71,12 @@ LoadPlugin wireless
 
 #<Plugin ping>
 #      Host "host.foo.bar"
+#      Interval 1.0
+#      Timeout 0.9
 #      TTL 255
+#      SourceAddress "1.2.3.4"
+#      Device "eth0"
+#      MaxMissed -1
 #</Plugin>
 
 #<Plugin processes>
index 6ac75225f36514abde0e8a41d7c1364e086fddd1..611a729c9db287d7f01aa468020410e1a8f8b068 100644 (file)
@@ -17,7 +17,7 @@
        /* consolidation_functions = */ NULL,
        /* consolidation_functions_num = */ 0
  };
-@@ -975,6 +978,14 @@ static int rrd_config (const char *key, 
+@@ -976,6 +979,14 @@ static int rrd_config (const char *key, 
  
                free (value_copy);
        }