mt76: update to Git HEAD (2023-12-18)
authorFelix Fietkau <nbd@nbd.name>
Mon, 18 Dec 2023 17:54:55 +0000 (18:54 +0100)
committerRafał Miłecki <rafal@milecki.pl>
Fri, 10 May 2024 09:45:43 +0000 (11:45 +0200)
bebd9cffc2ae wifi: mt76: mt7921: fix 6GHz disabled by the missing default CLC config

Signed-off-by: Felix Fietkau <nbd@nbd.name>
(cherry picked from commit 1a57d758f229a1e8d9085cd4775ebe7e1ec5d9b2)
[rmilecki: it's a no-change for 23.05 as we had that fix backported]

package/kernel/mt76/Makefile
package/kernel/mt76/patches/0002-wifi-mt76-mt7921-fix-6GHz-disabled-by-the-missing-de.patch [deleted file]

index 38a92c953ec6211f31d3ed2666f7b1b5def04f90..65f6ca1e8edd13ceda7f5f07df55ac218d607c8b 100644 (file)
@@ -8,9 +8,9 @@ PKG_LICENSE_FILES:=
 
 PKG_SOURCE_URL:=https://github.com/openwrt/mt76
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2023-12-11
-PKG_SOURCE_VERSION:=f63f87cd5b45c3779293e6062c6b26bdf57e851d
-PKG_MIRROR_HASH:=43f1b1fb75dfb4756aa1767983b338bd63154f0f6c45554029e69af49d55b914
+PKG_SOURCE_DATE:=2023-12-18
+PKG_SOURCE_VERSION:=bebd9cffc2aeb2cecb40aadbb8c6eab3bdf7971b
+PKG_MIRROR_HASH:=580261755bc3f251b8bc5f7f610274693c067432187570694d2f2ccab0edb62b
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 PKG_USE_NINJA:=0
diff --git a/package/kernel/mt76/patches/0002-wifi-mt76-mt7921-fix-6GHz-disabled-by-the-missing-de.patch b/package/kernel/mt76/patches/0002-wifi-mt76-mt7921-fix-6GHz-disabled-by-the-missing-de.patch
deleted file mode 100644 (file)
index 3fff9ca..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-From bebd9cffc2aeb2cecb40aadbb8c6eab3bdf7971b Mon Sep 17 00:00:00 2001
-From: Ming Yen Hsieh <mingyen.hsieh@mediatek.com>
-Date: Mon, 30 Oct 2023 15:17:34 +0800
-Subject: [PATCH] wifi: mt76: mt7921: fix 6GHz disabled by the missing default
- CLC config
-
-No matter CLC is enabled or disabled, the driver should initialize
-the default value 0xff for channel configuration of CLC. Otherwise,
-the zero value would disable channels.
-
-Reported-and-tested-by: Ben Greear <greearb@candelatech.com>
-Closes: https://lore.kernel.org/all/2fb78387-d226-3193-8ca7-90040561b9ad@candelatech.com/
-Fixes: 09382d8f8641 ("wifi: mt76: mt7921: update the channel usage when the regd domain changed")
-Signed-off-by: Ming Yen Hsieh <mingyen.hsieh@mediatek.com>
-Signed-off-by: Deren Wu <deren.wu@mediatek.com>
-Signed-off-by: Kalle Valo <kvalo@kernel.org>
-Link: https://lore.kernel.org/r/5a976ddf1f636b5cb809373501d3cfdc6d8de3e4.1698648737.git.deren.wu@mediatek.com
----
- mt7921/mcu.c | 1 +
- 1 file changed, 1 insertion(+)
-
---- a/mt7921/mcu.c
-+++ b/mt7921/mcu.c
-@@ -375,6 +375,7 @@ static int mt7921_load_clc(struct mt792x
-       int ret, i, len, offset = 0;
-       u8 *clc_base = NULL, hw_encap = 0;
-+      dev->phy.clc_chan_conf = 0xff;
-       if (mt7921_disable_clc ||
-           mt76_is_usb(&dev->mt76))
-               return 0;