fix xyssl headers install (closes: #2330), refresh patches.
authorNicolas Thill <nico@openwrt.org>
Sun, 23 Sep 2007 21:30:02 +0000 (21:30 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 23 Sep 2007 21:30:02 +0000 (21:30 +0000)
SVN-Revision: 9003

libs/xyssl/patches/001-cross_compile.patch
libs/xyssl/patches/002-install.patch

index baf27b2d2459bb1ca6a2aeea7be9cf6dcf6409e1..ce3092df5436b36652fdee672bc02ed4483bc914 100644 (file)
@@ -1,6 +1,7 @@
-diff -ruN xyssl-0.7-old/library/Makefile xyssl-0.7-new/library/Makefile
---- xyssl-0.7-old/library/Makefile     2007-07-07 07:07:00.000000000 +0200
-+++ xyssl-0.7-new/library/Makefile     2007-08-29 12:20:53.000000000 +0200
+Index: xyssl-0.7/library/Makefile
+===================================================================
+--- xyssl-0.7.orig/library/Makefile    2007-09-23 23:28:33.000000000 +0200
++++ xyssl-0.7/library/Makefile 2007-09-23 23:28:33.000000000 +0200
 @@ -9,10 +9,13 @@
  #    _BSD_EXTENSION     when compiling on Plan9
  
@@ -43,9 +44,10 @@ diff -ruN xyssl-0.7-old/library/Makefile xyssl-0.7-new/library/Makefile
  
  clean:
        rm -f *.o libxyssl.*
-diff -ruN xyssl-0.7-old/programs/Makefile xyssl-0.7-new/programs/Makefile
---- xyssl-0.7-old/programs/Makefile    2007-07-07 07:07:00.000000000 +0200
-+++ xyssl-0.7-new/programs/Makefile    2007-08-29 12:19:25.000000000 +0200
+Index: xyssl-0.7/programs/Makefile
+===================================================================
+--- xyssl-0.7.orig/programs/Makefile   2007-09-23 23:28:33.000000000 +0200
++++ xyssl-0.7/programs/Makefile        2007-09-23 23:28:33.000000000 +0200
 @@ -2,7 +2,8 @@
  # To compile on SunOS: add "-lsocket -lnsl" to LDFLAGS
  # To compile on MinGW: add "-lws2_32" to LDFLAGS
index 06c83070fde8bf1e89b3f27c44dd7e75f243b15c..d4fe3d0e8e5622ec5180f2ab175ef80e1791d946 100644 (file)
@@ -1,15 +1,18 @@
---- xyssl-0.7-old/Makefile     2007-07-07 07:07:00.000000000 +0200
-+++ xyssl-0.7-new/Makefile     2007-08-29 12:26:01.000000000 +0200
+Index: xyssl-0.7/Makefile
+===================================================================
+--- xyssl-0.7.orig/Makefile    2007-09-23 23:28:33.000000000 +0200
++++ xyssl-0.7/Makefile 2007-09-23 23:28:34.000000000 +0200
 @@ -8,9 +8,10 @@
        cd programs && make all && cd ..
  
  install:
 -      mkdir -p $(DESTDIR)/{include/xyssl,lib}
-+      mkdir -p $(DESTDIR)/include/xyssl
-       cp -v -r include $(DESTDIR)/include
+-      cp -v -r include $(DESTDIR)/include
 -      cp -v library/libxyssl.a $(DESTDIR)/lib
++      mkdir -p $(DESTDIR)/include/xyssl
++      cp -v -r include/* $(DESTDIR)/include/
 +      mkdir -p $(DESTDIR)/lib
-+      cp -v library/libxyssl.* $(DESTDIR)/lib
++      cp -v library/libxyssl.* $(DESTDIR)/lib/
        
        mkdir -p $(DESTDIR)/bin
        for p in programs/*/* ; do              \