projects
/
openwrt
/
staging
/
rmilecki.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
1e89670
)
base-files: link libpthread against libc
author
Felix Fietkau
<nbd@openwrt.org>
Mon, 14 Mar 2011 19:27:45 +0000
(19:27 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Mon, 14 Mar 2011 19:27:45 +0000
(19:27 +0000)
SVN-Revision: 26161
package/base-files/Makefile
patch
|
blob
|
history
diff --git
a/package/base-files/Makefile
b/package/base-files/Makefile
index b7fb07309eb18d7158ae1c4318a6d33c77a861a2..60f9f83b5c18625d2f62098a67a3172953cb7059 100644
(file)
--- a/
package/base-files/Makefile
+++ b/
package/base-files/Makefile
@@
-362,7
+362,7
@@
ifneq ($(BUILD_LIBGCC),)
"$(wildcard $(TOOLCHAIN_DIR)/lib/libpthread_so.a)" \
"$(patsubst $(TOOLCHAIN_DIR)/lib/%,$(PKG_BUILD_DIR)/%,$(wildcard $(TOOLCHAIN_DIR)/lib/libpthread-*.so))" \
-Wl,-z,nodelete,-z,initfirst,-init=__pthread_initialize_minimal_internal \
- -ldl $(BUILD_LIBGCC) \
+ -ldl
-lc
$(BUILD_LIBGCC) \
-Wl,-soname=libpthread.so.0
endef
define Build/Compile/libgcc