ltq-vdsl-vr11-app: exit more quickly if orderly shutdown fails
authorJan Hoffmann <jan@3e8.eu>
Thu, 30 Jan 2025 10:19:30 +0000 (11:19 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 22 Feb 2025 17:55:54 +0000 (18:55 +0100)
On exit, the app tries to do an orderly shutdown of the DSL connection
before it is stopped forcibly. Since the driver does 3 attempts with a
timeout of 2 seconds each, this might take about 6 seconds in the worst
case.

This is problematic on sysupgrade, because any process that doesn't exit
within 4 seconds is killed. This means that the DSL connection might not
be stopped at all before the actual system upgrade begins.

To avoid this, use the newly added option in the driver to not retry the
L3 request on failure.

Signed-off-by: Jan Hoffmann <jan@3e8.eu>
Link: https://patchwork.ozlabs.org/project/openwrt/patch/20250130102108.1606919-3-jan@3e8.eu/
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/network/config/ltq-vdsl-vr11-app/Makefile
package/network/config/ltq-vdsl-vr11-app/patches/201-orderly-shutdown.patch

index f1782db285c064d5c3982be9a6e095de86bb224a..2aacbbd785103c163b9a9bfd3a419451dcc2a953 100644 (file)
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ltq-vdsl-vr11-app
 PKG_VERSION:=4.23.1
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 PKG_BASE_NAME:=dsl_cpe_control
 
 UGW_VERSION=8.5.2.10
index eabeaaedcb9a87ba26e9e9a3435bfbeff1b1f5db..201b963fa0a172b829a2d2f3069ac53f9831ba5a 100644 (file)
@@ -45,7 +45,7 @@ is stopped on exit.
     {
 +      memset(&sPowerManagementStateForcedTrigger, 0x0,
 +         sizeof(DSL_G997_PowerManagementStateForcedTrigger_t));
-+      sPowerManagementStateForcedTrigger.data.nPowerManagementState = DSL_G997_PMSF_LX_TO_L3;
++      sPowerManagementStateForcedTrigger.data.nPowerManagementState = DSL_G997_PMSF_LX_TO_L3_NO_RETRY;
 +
 +      nRet = (DSL_Error_t)DSL_CPE_Ioctl(
 +         DSL_CPE_GetGlobalContext()->fd[nDevice],