include/trusted-firmware-a.mk: unset CC before compiling
authorThomas Richard <thomas.richard@bootlin.com>
Fri, 3 Jan 2025 09:19:05 +0000 (10:19 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 4 Jan 2025 17:11:40 +0000 (18:11 +0100)
If CC is explicitly set to a non default value, TF-A keeps this value.
Otherwise it assigns generic default value.
As the build bot set CC=/usr/bin/gcc-10, TF-A uses it which causes a
compile issue.
So unset CC before compiling.

It's a new behavior since v2.12. A part of the explanation is available in
this commit [1].

[1] https://github.com/ARM-software/arm-trusted-firmware/commit/e01c71266f9df46ac46dc72669449490d1c94419

Signed-off-by: Thomas Richard <thomas.richard@bootlin.com>
Link: https://github.com/openwrt/openwrt/pull/17465
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
include/trusted-firmware-a.mk

index c0d11d68c4beeff0dda33334c206d8ccee91f950..c329b76c56a4d7d2dd28100df82ee043273b2055 100644 (file)
@@ -77,7 +77,8 @@ endef
 DTC=$(wildcard $(LINUX_DIR)/scripts/dtc/dtc)
 
 define Build/Compile/Trusted-Firmware-A
-       +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
+       +unset CC; \
+       $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
                CROSS_COMPILE=$(TARGET_CROSS) \
                OPENSSL_DIR=$(STAGING_DIR_HOST) \
                $(if $(DTC),DTC="$(DTC)") \