projects
/
openwrt
/
staging
/
thess.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
b9a3592
)
sunxi: fix build of rtc package when module not available
author
Hauke Mehrtens
<hauke@hauke-m.de>
Sat, 15 Jul 2017 20:51:25 +0000
(22:51 +0200)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Mon, 18 Sep 2017 16:36:26 +0000
(18:36 +0200)
If the Kconfig option CONFIG_RTC_DRV_SUNXI is not selected this package
should be be build.
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/sunxi/modules.mk
patch
|
blob
|
history
diff --git
a/target/linux/sunxi/modules.mk
b/target/linux/sunxi/modules.mk
index 99b82a3b5f17348049458ced5823f7c90f784269..b8ea7d5cb66832d873024af7a5f66f2446681f06 100644
(file)
--- a/
target/linux/sunxi/modules.mk
+++ b/
target/linux/sunxi/modules.mk
@@
-10,8
+10,8
@@
define KernelPackage/rtc-sunxi
DEPENDS:=@TARGET_sunxi
$(call AddDepends/rtc)
KCONFIG:= \
- CONFIG_RTC_
CLASS=y
\
- CONFIG_RTC_
DRV_SUNXI=m
+ CONFIG_RTC_
DRV_SUNXI
\
+ CONFIG_RTC_
CLASS=y
FILES:=$(LINUX_DIR)/drivers/rtc/rtc-sunxi.ko
AUTOLOAD:=$(call AutoLoad,50,rtc-sunxi)
endef