tools: add iucode-tool
authorZoltan HERPAI <wigyori@uid0.hu>
Mon, 8 Jan 2018 14:37:02 +0000 (15:37 +0100)
committerZoltan HERPAI <wigyori@uid0.hu>
Mon, 8 Jan 2018 16:41:28 +0000 (17:41 +0100)
Add tool to "compile" Intel microcode files.

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
tools/iucode-tool/Makefile [new file with mode: 0644]

diff --git a/tools/iucode-tool/Makefile b/tools/iucode-tool/Makefile
new file mode 100644 (file)
index 0000000..c576b61
--- /dev/null
@@ -0,0 +1,31 @@
+#
+# Copyright (C) 2018 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=iucode-tool
+PKG_VERSION:=2.2
+PKG_RELEASE:=1
+
+PKG_SOURCE:=iucode-tool_$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=https://gitlab.com/iucode-tool/releases/raw/latest
+PKG_HASH:=9810daf925b8a9ca244adc4e1916bcab65601c9ebe87e91c2281f78055982971
+
+PKG_BUILD_DEPENDS:=USE_UCLIBC:argp-standalone USE_MUSL:argp-standalone
+
+PKG_MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
+PKG_LICENSE:=GPL-2.0
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Install
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/iucode_tool $(STAGING_DIR_HOST)/bin/iucode_tool
+endef
+
+$(eval $(call HostBuild))