OpenWrt v24.10: set branch defaults
authorChristian Marangi <ansuelsmth@gmail.com>
Thu, 31 Oct 2024 21:15:37 +0000 (22:15 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Thu, 31 Oct 2024 21:16:29 +0000 (22:16 +0100)
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
feeds.conf.default
include/version.mk
package/base-files/image-config.in

index fc679335e0e47fd66f7660355e5eb29111e6cfb4..581de056c41e3e73dcb1436f6b3ed7319bf0369a 100644 (file)
@@ -1,8 +1,4 @@
-src-git packages https://git.openwrt.org/feed/packages.git
-src-git luci https://git.openwrt.org/project/luci.git
-src-git routing https://git.openwrt.org/feed/routing.git
-src-git telephony https://git.openwrt.org/feed/telephony.git
-#src-git video https://github.com/openwrt/video.git
-#src-git targets https://github.com/openwrt/targets.git
-#src-git oldpackages http://git.openwrt.org/packages.git
-#src-link custom /usr/src/openwrt/custom-feed
+src-git packages https://git.openwrt.org/feed/packages.git;openwrt-24.10
+src-git luci https://git.openwrt.org/project/luci.git;openwrt-24.10
+src-git routing https://git.openwrt.org/feed/routing.git;openwrt-24.10
+src-git telephony https://git.openwrt.org/feed/telephony.git;openwrt-24.10
index 1ac29b629adb6b6eaeb18e45b853cad88b8fc6ca..a6ebe587797707fc258092b74c8f1687b60f08d3 100644 (file)
@@ -23,13 +23,13 @@ PKG_CONFIG_DEPENDS += \
 sanitize = $(call tolower,$(subst _,-,$(subst $(space),-,$(1))))
 
 VERSION_NUMBER:=$(call qstrip,$(CONFIG_VERSION_NUMBER))
-VERSION_NUMBER:=$(if $(VERSION_NUMBER),$(VERSION_NUMBER),SNAPSHOT)
+VERSION_NUMBER:=$(if $(VERSION_NUMBER),$(VERSION_NUMBER),24.10-SNAPSHOT)
 
 VERSION_CODE:=$(call qstrip,$(CONFIG_VERSION_CODE))
 VERSION_CODE:=$(if $(VERSION_CODE),$(VERSION_CODE),$(REVISION))
 
 VERSION_REPO:=$(call qstrip,$(CONFIG_VERSION_REPO))
-VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),https://downloads.openwrt.org/snapshots)
+VERSION_REPO:=$(if $(VERSION_REPO),$(VERSION_REPO),https://downloads.openwrt.org/releases/24.10-SNAPSHOT)
 
 VERSION_DIST:=$(call qstrip,$(CONFIG_VERSION_DIST))
 VERSION_DIST:=$(if $(VERSION_DIST),$(VERSION_DIST),OpenWrt)
index dee06e9b864b789084d11555f286d9a12f4e4109..80db993d46b837696910e01452ecb19fb351711e 100644 (file)
@@ -190,7 +190,7 @@ if VERSIONOPT
        config VERSION_REPO
                string
                prompt "Release repository"
-               default "https://downloads.openwrt.org/snapshots"
+               default "https://downloads.openwrt.org/releases/24.10-SNAPSHOT"
                help
                        This is the repository address embedded in the image, it defaults
                        to the trunk snapshot repo; the url may contain the following placeholders: