KVM: selftests: Move kvm_create_max_vcpus test to generic code
authorThomas Huth <thuth@redhat.com>
Thu, 23 May 2019 16:43:09 +0000 (18:43 +0200)
committerChristian Borntraeger <borntraeger@de.ibm.com>
Tue, 4 Jun 2019 12:05:38 +0000 (14:05 +0200)
There is nothing x86-specific in the test apart from the VM_MODE_P52V48_4K
which we can now replace with VM_MODE_DEFAULT. Thus let's move the file to
the main folder and enable it for aarch64 and s390x, too.

Reviewed-by: Andrew Jones <drjones@redhat.com>
Reviewed-by: David Hildenbrand <david@redhat.com>
Signed-off-by: Thomas Huth <thuth@redhat.com>
Message-Id: <20190523164309.13345-10-thuth@redhat.com>
Signed-off-by: Christian Borntraeger <borntraeger@de.ibm.com>
tools/testing/selftests/kvm/Makefile
tools/testing/selftests/kvm/kvm_create_max_vcpus.c [new file with mode: 0644]
tools/testing/selftests/kvm/x86_64/kvm_create_max_vcpus.c [deleted file]

index ed8eb6007566b0854ea109163ac149dfdeffd2e6..05a94a13a0a3105c0a842f3bddfae94af607c7c4 100644 (file)
@@ -22,15 +22,17 @@ TEST_GEN_PROGS_x86_64 += x86_64/evmcs_test
 TEST_GEN_PROGS_x86_64 += x86_64/hyperv_cpuid
 TEST_GEN_PROGS_x86_64 += x86_64/vmx_close_while_nested_test
 TEST_GEN_PROGS_x86_64 += x86_64/smm_test
-TEST_GEN_PROGS_x86_64 += x86_64/kvm_create_max_vcpus
 TEST_GEN_PROGS_x86_64 += x86_64/vmx_set_nested_state_test
+TEST_GEN_PROGS_x86_64 += kvm_create_max_vcpus
 TEST_GEN_PROGS_x86_64 += dirty_log_test
 TEST_GEN_PROGS_x86_64 += clear_dirty_log_test
 
 TEST_GEN_PROGS_aarch64 += dirty_log_test
 TEST_GEN_PROGS_aarch64 += clear_dirty_log_test
+TEST_GEN_PROGS_aarch64 += kvm_create_max_vcpus
 
 TEST_GEN_PROGS_s390x += s390x/sync_regs_test
+TEST_GEN_PROGS_s390x += kvm_create_max_vcpus
 
 TEST_GEN_PROGS += $(TEST_GEN_PROGS_$(UNAME_M))
 LIBKVM += $(LIBKVM_$(UNAME_M))
diff --git a/tools/testing/selftests/kvm/kvm_create_max_vcpus.c b/tools/testing/selftests/kvm/kvm_create_max_vcpus.c
new file mode 100644 (file)
index 0000000..db78ce0
--- /dev/null
@@ -0,0 +1,71 @@
+// SPDX-License-Identifier: GPL-2.0-only
+/*
+ * kvm_create_max_vcpus
+ *
+ * Copyright (C) 2019, Google LLC.
+ *
+ * This work is licensed under the terms of the GNU GPL, version 2.
+ *
+ * Test for KVM_CAP_MAX_VCPUS and KVM_CAP_MAX_VCPU_ID.
+ */
+
+#define _GNU_SOURCE /* for program_invocation_short_name */
+#include <fcntl.h>
+#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
+
+#include "test_util.h"
+
+#include "kvm_util.h"
+#include "asm/kvm.h"
+#include "linux/kvm.h"
+
+void test_vcpu_creation(int first_vcpu_id, int num_vcpus)
+{
+       struct kvm_vm *vm;
+       int i;
+
+       printf("Testing creating %d vCPUs, with IDs %d...%d.\n",
+              num_vcpus, first_vcpu_id, first_vcpu_id + num_vcpus - 1);
+
+       vm = vm_create(VM_MODE_DEFAULT, DEFAULT_GUEST_PHY_PAGES, O_RDWR);
+
+       for (i = 0; i < num_vcpus; i++) {
+               int vcpu_id = first_vcpu_id + i;
+
+               /* This asserts that the vCPU was created. */
+               vm_vcpu_add(vm, vcpu_id, 0, 0);
+       }
+
+       kvm_vm_free(vm);
+}
+
+int main(int argc, char *argv[])
+{
+       int kvm_max_vcpu_id = kvm_check_cap(KVM_CAP_MAX_VCPU_ID);
+       int kvm_max_vcpus = kvm_check_cap(KVM_CAP_MAX_VCPUS);
+
+       printf("KVM_CAP_MAX_VCPU_ID: %d\n", kvm_max_vcpu_id);
+       printf("KVM_CAP_MAX_VCPUS: %d\n", kvm_max_vcpus);
+
+       /*
+        * Upstream KVM prior to 4.8 does not support KVM_CAP_MAX_VCPU_ID.
+        * Userspace is supposed to use KVM_CAP_MAX_VCPUS as the maximum ID
+        * in this case.
+        */
+       if (!kvm_max_vcpu_id)
+               kvm_max_vcpu_id = kvm_max_vcpus;
+
+       TEST_ASSERT(kvm_max_vcpu_id >= kvm_max_vcpus,
+                   "KVM_MAX_VCPU_ID (%d) must be at least as large as KVM_MAX_VCPUS (%d).",
+                   kvm_max_vcpu_id, kvm_max_vcpus);
+
+       test_vcpu_creation(0, kvm_max_vcpus);
+
+       if (kvm_max_vcpu_id > kvm_max_vcpus)
+               test_vcpu_creation(
+                       kvm_max_vcpu_id - kvm_max_vcpus, kvm_max_vcpus);
+
+       return 0;
+}
diff --git a/tools/testing/selftests/kvm/x86_64/kvm_create_max_vcpus.c b/tools/testing/selftests/kvm/x86_64/kvm_create_max_vcpus.c
deleted file mode 100644 (file)
index 50e9299..0000000
+++ /dev/null
@@ -1,70 +0,0 @@
-/*
- * kvm_create_max_vcpus
- *
- * Copyright (C) 2019, Google LLC.
- *
- * This work is licensed under the terms of the GNU GPL, version 2.
- *
- * Test for KVM_CAP_MAX_VCPUS and KVM_CAP_MAX_VCPU_ID.
- */
-
-#define _GNU_SOURCE /* for program_invocation_short_name */
-#include <fcntl.h>
-#include <stdio.h>
-#include <stdlib.h>
-#include <string.h>
-
-#include "test_util.h"
-
-#include "kvm_util.h"
-#include "asm/kvm.h"
-#include "linux/kvm.h"
-
-void test_vcpu_creation(int first_vcpu_id, int num_vcpus)
-{
-       struct kvm_vm *vm;
-       int i;
-
-       printf("Testing creating %d vCPUs, with IDs %d...%d.\n",
-              num_vcpus, first_vcpu_id, first_vcpu_id + num_vcpus - 1);
-
-       vm = vm_create(VM_MODE_P52V48_4K, DEFAULT_GUEST_PHY_PAGES, O_RDWR);
-
-       for (i = 0; i < num_vcpus; i++) {
-               int vcpu_id = first_vcpu_id + i;
-
-               /* This asserts that the vCPU was created. */
-               vm_vcpu_add(vm, vcpu_id, 0, 0);
-       }
-
-       kvm_vm_free(vm);
-}
-
-int main(int argc, char *argv[])
-{
-       int kvm_max_vcpu_id = kvm_check_cap(KVM_CAP_MAX_VCPU_ID);
-       int kvm_max_vcpus = kvm_check_cap(KVM_CAP_MAX_VCPUS);
-
-       printf("KVM_CAP_MAX_VCPU_ID: %d\n", kvm_max_vcpu_id);
-       printf("KVM_CAP_MAX_VCPUS: %d\n", kvm_max_vcpus);
-
-       /*
-        * Upstream KVM prior to 4.8 does not support KVM_CAP_MAX_VCPU_ID.
-        * Userspace is supposed to use KVM_CAP_MAX_VCPUS as the maximum ID
-        * in this case.
-        */
-       if (!kvm_max_vcpu_id)
-               kvm_max_vcpu_id = kvm_max_vcpus;
-
-       TEST_ASSERT(kvm_max_vcpu_id >= kvm_max_vcpus,
-                   "KVM_MAX_VCPU_ID (%d) must be at least as large as KVM_MAX_VCPUS (%d).",
-                   kvm_max_vcpu_id, kvm_max_vcpus);
-
-       test_vcpu_creation(0, kvm_max_vcpus);
-
-       if (kvm_max_vcpu_id > kvm_max_vcpus)
-               test_vcpu_creation(
-                       kvm_max_vcpu_id - kvm_max_vcpus, kvm_max_vcpus);
-
-       return 0;
-}