--- a/arch/arm/mach-kirkwood/Makefile
+++ b/arch/arm/mach-kirkwood/Makefile
-@@ -8,6 +8,7 @@
+@@ -8,6 +8,7 @@ obj-$(CONFIG_MACH_SHEEVAPLUG) += sheeva
obj-$(CONFIG_MACH_DOCKSTAR) += dockstar-setup.o
obj-$(CONFIG_MACH_ESATA_SHEEVAPLUG) += sheevaplug-setup.o
obj-$(CONFIG_MACH_GURUPLUG) += guruplug-setup.o
obj-$(CONFIG_MACH_TS41X) += ts41x-setup.o tsx1x-common.o
obj-$(CONFIG_MACH_OPENRD) += openrd-setup.o
--- a/arch/arm/mach-kirkwood/Kconfig
-+++ b/arch/arm/mach-kirkwood/Kconfig
-@@ -105,6 +105,12 @@
++++ b/arch/arm/mach-kirkwood/Kconfig
+@@ -105,6 +105,12 @@ config MACH_DOCKSTAR
Say 'Y' here if you want your kernel to support the
Seagate FreeAgent DockStar.
endif
--- a/arch/arm/mach-kirkwood/mpp.h
-+++ b/arch/arm/mach-kirkwood/mpp.h
++++ b/arch/arm/mach-kirkwood/mpp.h
@@ -103,6 +103,7 @@
#define MPP11_SATA0_ACTn MPP( 11, 0x5, 0, 1, 0, 1, 1, 1 )
#define MPP12_SD_CLK MPP( 12, 0x1, 0, 1, 1, 1, 1, 1 )
#define MPP13_GPIO MPP( 13, 0x0, 1, 1, 1, 1, 1, 1 )
---- /dev/null
-+++ b/arch/arm/mach-kirkwood/iconnect-setup.c
-@@ -1,0 +1,190 @@
+--- /dev/null
++++ b/arch/arm/mach-kirkwood/iconnect-setup.c
+@@ -0,0 +1,190 @@
+/*
+ * arch/arm/mach-kirkwood/iconnect-setup.c
+ *