omap: adapt to the new dts directory layout.
authorAndre Heider <a.heider@gmail.com>
Sun, 4 Aug 2024 14:10:49 +0000 (16:10 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 15 Sep 2024 22:19:49 +0000 (00:19 +0200)
.dts files were moved to the 'ti/omap' sub-directory.

Signed-off-by: Andre Heider <a.heider@gmail.com>
Link: https://github.com/openwrt/openwrt/pull/16099
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/omap/image/Makefile
target/linux/omap/patches-6.6/900-use-cpsw-ethernet-driver.patch

index 507c91b2cc9aa5f33c73743940e5b8345316ae45..3d8c8a2f17235734171c9a5a4c25bf273a14791e 100644 (file)
@@ -33,6 +33,9 @@ define Device/Default
   PROFILES := Default
   KERNEL_NAME := zImage
   KERNEL := kernel-bin
+  ifdef CONFIG_LINUX_6_6
+  DTS_DIR := $(DTS_DIR)/ti/omap
+  endif
   DEVICE_DTS = $(lastword $(subst _, ,$(1)))
   IMAGES := sdcard.img.gz
   IMAGE/sdcard.img.gz := omap-sdcard | append-metadata | gzip
index 17c07fbdfba1110dabcf6287ac1a31efd592a8a8..31fa0028c6eed0feec163356a77c2357af20d92c 100644 (file)
@@ -17,9 +17,9 @@ devices in OpenWrt usable again with the default network config.)
 Signed-off-by: Jan Hoffmann <jan@3e8.eu>
 ---
 
---- a/arch/arm/boot/dts/am335x-bone-common.dtsi
-+++ b/arch/arm/boot/dts/am335x-bone-common.dtsi
-@@ -353,27 +353,24 @@
+--- a/arch/arm/boot/dts/ti/omap/am335x-bone-common.dtsi
++++ b/arch/arm/boot/dts/ti/omap/am335x-bone-common.dtsi
+@@ -358,27 +358,24 @@
        };
  };
  
@@ -52,8 +52,8 @@ Signed-off-by: Jan Hoffmann <jan@3e8.eu>
  
        ethphy0: ethernet-phy@0 {
                reg = <0>;
---- a/arch/arm/boot/dts/am335x-evm.dts
-+++ b/arch/arm/boot/dts/am335x-evm.dts
+--- a/arch/arm/boot/dts/ti/omap/am335x-evm.dts
++++ b/arch/arm/boot/dts/ti/omap/am335x-evm.dts
 @@ -682,31 +682,28 @@
        };
  };