projects
/
openwrt
/
staging
/
jow.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
2395324
)
build: for cmake, always use ccache from staging dir instead of relying on the host
author
Felix Fietkau
<nbd@openwrt.org>
Sun, 3 Jan 2016 14:44:30 +0000
(14:44 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sun, 3 Jan 2016 14:44:30 +0000
(14:44 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 48079
include/cmake.mk
patch
|
blob
|
history
diff --git
a/include/cmake.mk
b/include/cmake.mk
index 4207a4dcee8444ac1472b2b78a068e5ed811c7ae..4e4169a132c71f21c99d24d3af81b0e3d8837a70 100644
(file)
--- a/
include/cmake.mk
+++ b/
include/cmake.mk
@@
-18,10
+18,7
@@
ifeq ($(CONFIG_CCACHE),)
CMAKE_C_COMPILER_ARG1:=
CMAKE_CXX_COMPILER_ARG1:=
else
- CCACHE:=$(shell which ccache)
- ifeq ($(CCACHE),)
- CCACHE:=$(STAGING_DIR_HOST)/bin/ccache
- endif
+ CCACHE:=$(STAGING_DIR_HOST)/bin/ccache
CMAKE_C_COMPILER:=$(CCACHE)
CMAKE_C_COMPILER_ARG1:=$(TARGET_CC_NOCACHE)
CMAKE_CXX_COMPILER:=$(CCACHE)