ipq40xx: switch to zImage kernel for SKSpruce WIA3300-20
authorShiji Yang <yangshiji66@qq.com>
Fri, 11 Oct 2024 10:40:16 +0000 (18:40 +0800)
committerRobert Marko <robimarko@gmail.com>
Fri, 11 Oct 2024 14:32:57 +0000 (16:32 +0200)
The bootloader can support zImage linux kernel which can decrease
the firmware image size.

Signed-off-by: Shiji Yang <yangshiji66@qq.com>
Link: https://github.com/openwrt/openwrt/pull/16662
Signed-off-by: Robert Marko <robimarko@gmail.com>
target/linux/ipq40xx/image/generic.mk

index b5d387b14a06c02d185cb0cd6bfc40da33388fbd..478e399d0cedec0fff37caef7163248b9abf3da5 100644 (file)
@@ -1093,7 +1093,7 @@ endef
 TARGET_DEVICES += qxwlan_e2600ac-c2
 
 define Device/skspruce_wia3300-20
-       $(call Device/FitImage)
+       $(call Device/FitzImage)
        BLOCKSIZE := 64k
        IMAGE_SIZE := 55104k
        SOC := qcom-ipq4019