projects
/
openwrt
/
staging
/
lynxis.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
634c733
)
mac80211: add ABI_VERSION to fix rebuild of dependent packages after upgrades
author
Felix Fietkau
<nbd@nbd.name>
Sun, 6 Jan 2019 20:48:02 +0000
(21:48 +0100)
committer
Felix Fietkau
<nbd@nbd.name>
Sun, 6 Jan 2019 20:48:11 +0000
(21:48 +0100)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/kernel/mac80211/Makefile
patch
|
blob
|
history
diff --git
a/package/kernel/mac80211/Makefile
b/package/kernel/mac80211/Makefile
index 5f79e54edf3ccc266f6463984fb93b92c807482c..6b23ec5a24aebeeaa69dda934bc8409f1bd4c85d 100644
(file)
--- a/
package/kernel/mac80211/Makefile
+++ b/
package/kernel/mac80211/Makefile
@@
-98,6
+98,7
@@
define KernelPackage/cfg80211
$(call KernelPackage/mac80211/Default)
TITLE:=cfg80211 - wireless configuration API
DEPENDS+= +iw +wireless-regdb
+ ABI_VERSION:=$(PKG_VERSION)-$(PKG_RELEASE)
FILES:= \
$(PKG_BUILD_DIR)/compat/compat.ko \
$(PKG_BUILD_DIR)/net/wireless/cfg80211.ko
@@
-115,6
+116,7
@@
define KernelPackage/mac80211
KCONFIG:=\
CONFIG_AVERAGE=y
FILES:= $(PKG_BUILD_DIR)/net/mac80211/mac80211.ko
+ ABI_VERSION:=$(PKG_VERSION)-$(PKG_RELEASE)
MENU:=1
endef