enable xsltproc package... courtesy of coova
authorTim Yardley <lst@openwrt.org>
Wed, 2 May 2007 19:33:48 +0000 (19:33 +0000)
committerTim Yardley <lst@openwrt.org>
Wed, 2 May 2007 19:33:48 +0000 (19:33 +0000)
SVN-Revision: 7080

libs/libxslt/Makefile

index 8c0cb389c739310b0599a215148c29292c3e7c0a..7c2ee4b20bfcbc4d3a02de5d8a6cc8de497d59ae 100644 (file)
@@ -33,6 +33,16 @@ define Package/libxslt
   URL:=http://xmlsoft.org/XSLT/
 endef
 
+define Package/xsltproc
+  SECTION:=utils
+  CATEGORY:=Utilities
+  DEPENDS:=+libxml2 +libxslt
+  TITLE:=Gnome XSLT xsltproc Utility
+  DESCRIPTION:=\
+       XSLT XML transformation utility
+  URL:=http://xmlsoft.org/XSLT/
+endef
+
 define Build/Configure
        $(call Build/Configure/Default, \
                --enable-shared \
@@ -88,4 +98,10 @@ define Package/libxslt/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libxslt.so.* $(1)/usr/lib/
 endef
 
+define Package/xsltproc/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/xsltproc $(1)/usr/bin/
+endef
+
 $(eval $(call BuildPackage,libxslt))
+$(eval $(call BuildPackage,xsltproc))