projects
/
openwrt
/
staging
/
nbd.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
9e670fc
)
build: include homebrew include/library directory in cflags/ldflags on mac os x
author
Felix Fietkau
<nbd@openwrt.org>
Mon, 5 Oct 2015 14:11:30 +0000
(14:11 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Mon, 5 Oct 2015 14:11:30 +0000
(14:11 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 47139
include/host-build.mk
patch
|
blob
|
history
diff --git
a/include/host-build.mk
b/include/host-build.mk
index 760d38b371f8fcb6af7acfcc3bd07e65647b0ae6..e2b5f2f8d1882207e11697df3df1302076adfaa3 100644
(file)
--- a/
include/host-build.mk
+++ b/
include/host-build.mk
@@
-50,6
+50,11
@@
define Host/Prepare
$(call Host/Prepare/Default)
endef
+ifeq ($(HOST_OS),Darwin)
+ HOST_CFLAGS += -I/usr/local/opt/openssl/include
+ HOST_LDFLAGS += -L/usr/local/opt/openssl/lib
+endif
+
HOST_CONFIGURE_VARS = \
CC="$(HOSTCC)" \
CFLAGS="$(HOST_CFLAGS)" \