projects
/
openwrt
/
staging
/
ynezz.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
bbc4c10
)
fix potential build errors when changing the qc-usb package selection
author
Felix Fietkau
<nbd@openwrt.org>
Sun, 6 Jan 2008 02:12:40 +0000
(
02:12
+0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sun, 6 Jan 2008 02:12:40 +0000
(
02:12
+0000)
SVN-Revision: 10124
package/qc-usb/Makefile
patch
|
blob
|
history
diff --git
a/package/qc-usb/Makefile
b/package/qc-usb/Makefile
index ff41469b326d330f41b584a56619031024baa14f..47afc8c28bbb7ff151d09e46cd3a00e34af3f8ec 100644
(file)
--- a/
package/qc-usb/Makefile
+++ b/
package/qc-usb/Makefile
@@
-58,8
+58,7
@@
ifeq ($(KERNEL),2.4)
endif
endif
-ifneq ($(CONFIG_PACKAGE_kmod-video-quickcam),)
- define Build/Compile/kmod
+define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
LINUX_DIR="$(LINUX_DIR)" \
ARCH="$(LINUX_KARCH)" \
@@
-68,11
+67,6
@@
ifneq ($(CONFIG_PACKAGE_kmod-video-quickcam),)
LD="$(TARGET_CC) -nodefaultlibs -nostartfiles" \
USER_OPT="$(KERNEL_C_OPTS)" \
quickcam.$(LINUX_KMOD_SUFFIX)
- endef
-endif
-
-define Build/Compile
- $(call Build/Compile/kmod)
$(MAKE) -C $(PKG_BUILD_DIR) \
CFLAGS="$(TARGET_CFLAGS)" \
qcset