sunxi: add support for Retro Games Limited C=64 Mini (RGL001)
authorZoltan HERPAI <wigyori@uid0.hu>
Wed, 13 Mar 2019 20:59:13 +0000 (21:59 +0100)
committerZoltan HERPAI <wigyori@uid0.hu>
Mon, 26 Aug 2019 09:33:10 +0000 (11:33 +0200)
CPU: Allwinner A20 dual-core Cortex A7
Memory: 256/512Mb
Storage: 128Mb NAND
USB: 2x USB2.0

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
package/boot/uboot-sunxi/Makefile
target/linux/sunxi/image/cortex-a7.mk
target/linux/sunxi/patches-4.19/401-dts-add-rgl-C64mini.patch [new file with mode: 0644]

index 0f5bc90283f11a81ffa865a1611a1ed10b513844..425e6ac6482821a019d1631d2825a9da379050df 100644 (file)
@@ -253,6 +253,12 @@ define U-Boot/orangepi_pc2
   UENV:=a64
 endef
 
+define U-Boot/rgl_c64mini
+  BUILD_SUBTARGET:=cortexa7
+  NAME:=U-Boot for Retro Games Ltd. C=64 Mini (A20)
+  BUILD_DEVICES:=sun7i-a20-rgl-c64mini
+endef
+
 UBOOT_TARGETS := \
        A10-OLinuXino-Lime \
        A13-OLinuXino \
@@ -286,6 +292,7 @@ UBOOT_TARGETS := \
        orangepi_pc2 \
        pangolin \
        pine64_plus \
+       rgl_c64mini \
        Sinovoip_BPI_M2_Plus \
        Sinovoip_BPI_M3 \
        sopine_baseboard \
index 17a5c1b3d7c7bab2ef93ca279308999e4c4e12f6..6c6de6e508fb1164583a0f281ea4e97a973656a4 100644 (file)
@@ -108,6 +108,16 @@ endef
 TARGET_DEVICES += sun7i-a20-lamobo-r1
 
 
+define Device/sun7i-a20-rgl-c64mini
+  DEVICE_TITLE:=Retro Games RGL001 (C=64 Mini)
+  DEVICE_PACKAGES:=kmod-rtc-sunxi
+  SUPPORTED_DEVICES:=rgl,c64mini
+  SUNXI_DTS:=sun7i-a20-rgl-c64mini
+endef
+
+TARGET_DEVICES += sun7i-a20-rgl-c64mini
+
+
 define Device/sun6i-a31-m9
   DEVICE_VENDOR := Mele
   DEVICE_MODEL := M9
diff --git a/target/linux/sunxi/patches-4.19/401-dts-add-rgl-C64mini.patch b/target/linux/sunxi/patches-4.19/401-dts-add-rgl-C64mini.patch
new file mode 100644 (file)
index 0000000..e02f3fd
--- /dev/null
@@ -0,0 +1,227 @@
+diff -ruN a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
+--- a/arch/arm/boot/dts/Makefile       2019-02-06 17:30:16.000000000 +0100
++++ b/arch/arm/boot/dts/Makefile       2019-02-13 17:48:08.493420738 +0100
+@@ -1006,6 +1006,7 @@
+       sun7i-a20-orangepi-mini.dtb \
+       sun7i-a20-pcduino3.dtb \
+       sun7i-a20-pcduino3-nano.dtb \
++      sun7i-a20-rgl-c64mini.dtb \
+       sun7i-a20-wexler-tab7200.dtb \
+       sun7i-a20-wits-pro-a20-dkt.dtb
+ dtb-$(CONFIG_MACH_SUN8I) += \
+diff -ruN a/arch/arm/boot/dts/sun7i-a20-rgl-c64mini.dts b/arch/arm/boot/dts/sun7i-a20-rgl-c64mini.dts
+--- a/arch/arm/boot/dts/sun7i-a20-rgl-c64mini.dts      1970-01-01 01:00:00.000000000 +0100
++++ b/arch/arm/boot/dts/sun7i-a20-rgl-c64mini.dts      2019-02-13 17:54:22.550445293 +0100
+@@ -0,0 +1,212 @@
++/*
++ * This is based on sun4i-a10-olinuxino-lime.dts
++ *
++ * Copyright 2014 - Hans de Goede <hdegoede@redhat.com>
++ * Copyright (c) 2014 FUKAUMI Naoki <naobsd@gmail.com>
++ *
++ * This file is dual-licensed: you can use it either under the terms
++ * of the GPL or the X11 license, at your option. Note that this dual
++ * licensing only applies to this file, and not this project as a
++ * whole.
++ *
++ *  a) This file is free software; you can redistribute it and/or
++ *     modify it under the terms of the GNU General Public License as
++ *     published by the Free Software Foundation; either version 2 of the
++ *     License, or (at your option) any later version.
++ *
++ *     This file is distributed in the hope that it will be useful,
++ *     but WITHOUT ANY WARRANTY; without even the implied warranty of
++ *     MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
++ *     GNU General Public License for more details.
++ *
++ * Or, alternatively,
++ *
++ *  b) Permission is hereby granted, free of charge, to any person
++ *     obtaining a copy of this software and associated documentation
++ *     files (the "Software"), to deal in the Software without
++ *     restriction, including without limitation the rights to use,
++ *     copy, modify, merge, publish, distribute, sublicense, and/or
++ *     sell copies of the Software, and to permit persons to whom the
++ *     Software is furnished to do so, subject to the following
++ *     conditions:
++ *
++ *     The above copyright notice and this permission notice shall be
++ *     included in all copies or substantial portions of the Software.
++ *
++ *     THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
++ *     EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES
++ *     OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
++ *     NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT
++ *     HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
++ *     WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
++ *     FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
++ *     OTHER DEALINGS IN THE SOFTWARE.
++ */
++
++/dts-v1/;
++#include "sun7i-a20.dtsi"
++#include "sunxi-common-regulators.dtsi"
++
++#include <dt-bindings/gpio/gpio.h>
++#include <dt-bindings/interrupt-controller/irq.h>
++
++/ {
++      model = "Retro Games C=64 Mini";
++      compatible = "rgl,c64-mini", "allwinner,sun7i-a20";
++
++      aliases {
++              serial0 = &uart0;
++      };
++
++      chosen {
++              stdout-path = "serial0:115200n8";
++      };
++
++      hdmi-connector {
++              compatible = "hdmi-connector";
++              type = "a";
++
++              port {
++                      hdmi_con_in: endpoint {
++                              remote-endpoint = <&hdmi_out_con>;
++                      };
++              };
++      };
++
++      leds {
++              compatible = "gpio-leds";
++              pinctrl-names = "default";
++              pinctrl-0 = <&led_pins_olinuxinolime>;
++
++              green {
++                      label = "a20-olinuxino-lime:green:usr";
++                      gpios = <&pio 7 2 GPIO_ACTIVE_HIGH>;
++                      default-state = "on";
++              };
++      };
++};
++
++&de {
++      status = "okay";
++};
++
++&ehci0 {
++      status = "okay";
++};
++
++&ehci1 {
++      status = "okay";
++};
++
++&hdmi {
++      status = "okay";
++};
++
++&hdmi_out {
++      hdmi_out_con: endpoint {
++              remote-endpoint = <&hdmi_con_in>;
++      };
++};
++
++&i2c0 {
++      pinctrl-names = "default";
++      pinctrl-0 = <&i2c0_pins_a>;
++      status = "okay";
++
++      axp209: pmic@34 {
++              compatible = "x-powers,axp209";
++              reg = <0x34>;
++              interrupt-parent = <&nmi_intc>;
++              interrupts = <0 IRQ_TYPE_LEVEL_LOW>;
++
++              interrupt-controller;
++              #interrupt-cells = <1>;
++      };
++};
++
++&i2c1 {
++      pinctrl-names = "default";
++      pinctrl-0 = <&i2c1_pins_a>;
++      status = "okay";
++
++      eeprom: eeprom@50 {
++              compatible = "atmel,24c16";
++              reg = <0x50>;
++              pagesize = <16>;
++      };
++};
++
++&mmc0 {
++      pinctrl-names = "default";
++      pinctrl-0 = <&mmc0_pins_a>;
++      vmmc-supply = <&reg_vcc3v3>;
++      bus-width = <4>;
++      cd-gpios = <&pio 7 1 GPIO_ACTIVE_LOW>; /* PH1 */
++      status = "okay";
++};
++
++&ohci0 {
++      status = "okay";
++};
++
++&ohci1 {
++      status = "okay";
++};
++
++&otg_sram {
++      status = "okay";
++};
++
++&pio {
++      led_pins_olinuxinolime: led_pins@0 {
++              pins = "PH2";
++              function = "gpio_out";
++              drive-strength = <20>;
++      };
++
++      usb0_id_detect_pin: usb0_id_detect_pin@0 {
++              pins = "PH4";
++              function = "gpio_in";
++              bias-pull-up;
++      };
++
++      usb0_vbus_detect_pin: usb0_vbus_detect_pin@0 {
++              pins = "PH5";
++              function = "gpio_in";
++              bias-pull-down;
++      };
++};
++
++&reg_usb0_vbus {
++      status = "okay";
++};
++
++&reg_usb1_vbus {
++      status = "okay";
++};
++
++&reg_usb2_vbus {
++      status = "okay";
++};
++
++&uart0 {
++      pinctrl-names = "default";
++      pinctrl-0 = <&uart0_pins_a>;
++      status = "okay";
++};
++
++&usb_otg {
++      dr_mode = "otg";
++      status = "okay";
++};
++
++&usbphy {
++      pinctrl-names = "default";
++      pinctrl-0 = <&usb0_id_detect_pin>, <&usb0_vbus_detect_pin>;
++      usb0_id_det-gpio = <&pio 7 4 GPIO_ACTIVE_HIGH>; /* PH4 */
++      usb0_vbus_det-gpio = <&pio 7 5 GPIO_ACTIVE_HIGH>; /* PH5 */
++      usb0_vbus-supply = <&reg_usb0_vbus>;
++      usb1_vbus-supply = <&reg_usb1_vbus>;
++      usb2_vbus-supply = <&reg_usb2_vbus>;
++      status = "okay";
++};