compat-wireless: refresh patches for linux-next next-20101217
authorLuis R. Rodriguez <lrodriguez@atheros.com>
Sat, 18 Dec 2010 20:18:02 +0000 (12:18 -0800)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Sat, 18 Dec 2010 20:18:02 +0000 (12:18 -0800)
Signed-off-by: Luis R. Rodriguez <lrodriguez@atheros.com>
15 files changed:
patches/01-netdev.patch
patches/02-ksize.patch
patches/04-netns.patch
patches/05-usb.patch
patches/08-rename-iwl4965-config.patch
patches/09-threaded-irq.patch
patches/11-dev-pm-ops.patch
patches/14-device-type.patch
patches/15-symbol-export-conflicts.patch
patches/16-bluetooth.patch
patches/18-rename-usb-net-symbols.patch
patches/19-kfifo.patch
patches/22-multiqueue.patch
patches/30-bridge-port.patch
patches/36-workqueue.patch

index 054e34b36b9b835ba115fe6873d6102f8b93ff04..64b5fbd3dccd3c0d6cfec0ebbd73e32a79cf9ca0 100644 (file)
@@ -23,7 +23,7 @@ without creating a headache on maintenance of the pathes.
        if (unlikely(retval < 0)) {
 --- a/drivers/net/usb/usbnet.c
 +++ b/drivers/net/usb/usbnet.c
-@@ -1360,7 +1360,7 @@ usbnet_probe (struct usb_interface *udev
+@@ -1359,7 +1359,7 @@ usbnet_probe (struct usb_interface *udev
                net->features |= NETIF_F_HIGHDMA;
  #endif
  
index 21b7c7ba45643b2d637ba64a2a7720b40a80b70c..0f51bcb4404a0bae5fdc5db5379d0b997de80df4 100644 (file)
@@ -52,9 +52,9 @@ of the situation.
                                memcpy(found->pub.proberesp_ies,
                                       res->pub.proberesp_ies, ielen);
                                found->pub.len_proberesp_ies = ielen;
-@@ -465,9 +470,14 @@ cfg80211_bss_update(struct cfg80211_regi
-                       size_t used = dev->wiphy.bss_priv_size + sizeof(*res);
-                       size_t ielen = res->pub.len_beacon_ies;
+@@ -468,9 +473,14 @@ cfg80211_bss_update(struct cfg80211_regi
+                               (found->pub.information_elements ==
+                                found->pub.beacon_ies);
  
 +#if LINUX_VERSION_CODE <= KERNEL_VERSION(2,6,28)
 +                      if (0) {
index 060bb5b6c88d7d9a986e3c375128f2a8d1d63247..e66e237cb2b50da82bc10022fe5b0e68ad0aa5e1 100644 (file)
@@ -6,7 +6,7 @@ files...
 
 --- a/net/wireless/nl80211.c
 +++ b/net/wireless/nl80211.c
-@@ -4045,7 +4045,9 @@ static int nl80211_wiphy_netns(struct sk
+@@ -4149,7 +4149,9 @@ static int nl80211_wiphy_netns(struct sk
        if (!net_eq(wiphy_net(&rdev->wiphy), net))
                err = cfg80211_switch_netns(rdev, net);
  
index 4f0b9f3e16c81efc254bb00776be385ce77f2ac3..03aa1be486a96074562c8d8a492525af2b00a018 100644 (file)
@@ -2,7 +2,7 @@ USB opt soft_unbid was added as of 2.6.27.
 
 --- a/drivers/net/wireless/p54/p54usb.c
 +++ b/drivers/net/wireless/p54/p54usb.c
-@@ -1069,7 +1069,9 @@ static struct usb_driver p54u_driver = {
+@@ -1075,7 +1075,9 @@ static struct usb_driver p54u_driver = {
        .resume = p54u_resume,
        .reset_resume = p54u_resume,
  #endif /* CONFIG_PM */
@@ -14,7 +14,7 @@ USB opt soft_unbid was added as of 2.6.27.
  static int __init p54u_init(void)
 --- a/drivers/net/wireless/ath/ath9k/hif_usb.c
 +++ b/drivers/net/wireless/ath/ath9k/hif_usb.c
-@@ -1073,7 +1073,9 @@ static struct usb_driver ath9k_hif_usb_d
+@@ -1074,7 +1074,9 @@ static struct usb_driver ath9k_hif_usb_d
        .reset_resume = ath9k_hif_usb_resume,
  #endif
        .id_table = ath9k_hif_usb_ids,
index 2de5767ee99fedb5ddc6fbcd1fc8742127658c36..c4a94d992add673d2387400780caf57aa77b0e41 100644 (file)
@@ -5,7 +5,7 @@ CONFIG_IWL4965 has to be set to y, to build correctly.
 
 --- a/drivers/net/wireless/Makefile
 +++ b/drivers/net/wireless/Makefile
-@@ -40,7 +40,7 @@ obj-$(CONFIG_ADM8211)        += adm8211.o
+@@ -41,7 +41,7 @@ obj-$(CONFIG_ADM8211)        += adm8211.o
  
  obj-$(CONFIG_MWL8K)   += mwl8k.o
  
index 060d9acd829ea34bb4c64a3fc04fe4c743ba904a..a0a55afc21856def28777b29bec8b1a49e67efd1 100644 (file)
@@ -6,7 +6,7 @@ thread in process context as well.
 
 --- a/drivers/net/wireless/b43/main.c
 +++ b/drivers/net/wireless/b43/main.c
-@@ -3952,8 +3952,13 @@ redo:
+@@ -3948,8 +3948,13 @@ redo:
        if (dev->dev->bus->bustype == SSB_BUSTYPE_SDIO) {
                b43_sdio_free_irq(dev);
        } else {
@@ -20,7 +20,7 @@ thread in process context as well.
        }
        mutex_lock(&wl->mutex);
        dev = wl->current_dev;
-@@ -3993,9 +3998,17 @@ static int b43_wireless_core_start(struc
+@@ -3989,9 +3994,17 @@ static int b43_wireless_core_start(struc
                        goto out;
                }
        } else {
@@ -38,7 +38,7 @@ thread in process context as well.
                if (err) {
                        b43err(dev->wl, "Cannot request IRQ-%d\n", dev->dev->irq);
                        goto out;
-@@ -4724,6 +4737,10 @@ static int b43_setup_bands(struct b43_wl
+@@ -4720,6 +4733,10 @@ static int b43_setup_bands(struct b43_wl
  
  static void b43_wireless_core_detach(struct b43_wldev *dev)
  {
@@ -63,7 +63,7 @@ thread in process context as well.
  /* Data structure for the WLAN parts (802.11 cores) of the b43 chip. */
 --- a/drivers/net/wireless/rt2x00/rt2x00.h
 +++ b/drivers/net/wireless/rt2x00/rt2x00.h
-@@ -908,6 +908,10 @@ struct rt2x00_dev {
+@@ -914,6 +914,10 @@ struct rt2x00_dev {
         * Tasklet for processing tx status reports (rt2800pci).
         */
        struct tasklet_struct txstatus_tasklet;
@@ -76,7 +76,7 @@ thread in process context as well.
  /*
 --- a/drivers/net/wireless/rt2x00/rt2x00pci.c
 +++ b/drivers/net/wireless/rt2x00/rt2x00pci.c
-@@ -153,10 +153,18 @@ int rt2x00pci_initialize(struct rt2x00_d
+@@ -160,10 +160,18 @@ int rt2x00pci_initialize(struct rt2x00_d
        /*
         * Register interrupt handler.
         */
@@ -95,7 +95,7 @@ thread in process context as well.
        if (status) {
                ERROR(rt2x00dev, "IRQ %d allocation failed (error %d).\n",
                      rt2x00dev->irq, status);
-@@ -180,7 +188,11 @@ void rt2x00pci_uninitialize(struct rt2x0
+@@ -187,7 +195,11 @@ void rt2x00pci_uninitialize(struct rt2x0
        /*
         * Free irq line.
         */
@@ -107,7 +107,7 @@ thread in process context as well.
  
        /*
         * Free DMA
-@@ -195,6 +207,9 @@ EXPORT_SYMBOL_GPL(rt2x00pci_uninitialize
+@@ -202,6 +214,9 @@ EXPORT_SYMBOL_GPL(rt2x00pci_uninitialize
   */
  static void rt2x00pci_free_reg(struct rt2x00_dev *rt2x00dev)
  {
index b49433ab3a7b12347c263f67f71d06c62d8a8aeb..f30baf86097e1da4b1ef82e7e45aa1fa2da72dab 100644 (file)
@@ -9,7 +9,7 @@ calls on compat code with only slight modifications.
 
 --- a/drivers/net/wireless/ath/ath9k/pci.c
 +++ b/drivers/net/wireless/ath/ath9k/pci.c
-@@ -312,14 +312,36 @@ static int ath_pci_resume(struct device
+@@ -315,14 +315,36 @@ static int ath_pci_resume(struct device
        return 0;
  }
  
@@ -54,7 +54,7 @@ calls on compat code with only slight modifications.
  
  #define ATH9K_PM_OPS  (&ath9k_pm_ops)
  
-@@ -337,7 +359,12 @@ static struct pci_driver ath_pci_driver
+@@ -340,7 +362,12 @@ static struct pci_driver ath_pci_driver
        .id_table   = ath_pci_id_table,
        .probe      = ath_pci_probe,
        .remove     = ath_pci_remove,
@@ -84,7 +84,7 @@ calls on compat code with only slight modifications.
  static int __init iwl_init(void)
 --- a/drivers/net/wireless/iwlwifi/iwl-core.c
 +++ b/drivers/net/wireless/iwlwifi/iwl-core.c
-@@ -2081,14 +2081,42 @@ int iwl_pci_resume(struct device *device
+@@ -2098,14 +2098,42 @@ int iwl_pci_resume(struct device *device
  }
  EXPORT_SYMBOL(iwl_pci_resume);
  
@@ -137,7 +137,7 @@ calls on compat code with only slight modifications.
  #endif /* CONFIG_PM */
 --- a/drivers/net/wireless/iwlwifi/iwl-core.h
 +++ b/drivers/net/wireless/iwlwifi/iwl-core.h
-@@ -631,7 +631,12 @@ __le32 iwl_add_beacon_time(struct iwl_pr
+@@ -635,7 +635,12 @@ __le32 iwl_add_beacon_time(struct iwl_pr
  #ifdef CONFIG_PM
  int iwl_pci_suspend(struct device *device);
  int iwl_pci_resume(struct device *device);
index 11f6136e037db9e30040736fec1ebe6b0ebcdae9..b801ed9c53da1db7e064d5fa985e309f8a714a6d 100644 (file)
@@ -36,7 +36,7 @@ compile warning.
  {
 --- a/drivers/net/usb/usbnet.c
 +++ b/drivers/net/usb/usbnet.c
-@@ -1273,13 +1273,17 @@ static const struct net_device_ops usbne
+@@ -1272,13 +1272,17 @@ static const struct net_device_ops usbne
  
  // precondition: never called in_interrupt
  
index 6dbb0c13ca4a8a462afc15fc647be9cd36bf7046..661652dd6a41bb1c55791721f3395509088acf94 100644 (file)
@@ -3,7 +3,7 @@ To avoid conflicts with the other export we rename our.
 
 --- a/net/mac80211/rx.c
 +++ b/net/mac80211/rx.c
-@@ -2896,7 +2896,12 @@ void ieee80211_rx(struct ieee80211_hw *h
+@@ -2933,7 +2933,12 @@ void ieee80211_rx(struct ieee80211_hw *h
   drop:
        kfree_skb(skb);
  }
index e528e9920944ce5db804796a2d73d0945838ca45..6c0e13b3e7ac946a32578ea8bea6dc129ed7569d 100644 (file)
@@ -17,7 +17,7 @@ here still, but for now we keep this here.
        tty_driver_flush_buffer(tty);
  
        return 0;
-@@ -495,7 +500,11 @@ static int hci_uart_tty_ioctl(struct tty
+@@ -497,7 +502,11 @@ static int hci_uart_tty_ioctl(struct tty
                return hu->hdev_flags;
  
        default:
index 548a7a4967729e967ea15ac9ad34753bf1c21ea1..f10d0f46b9eb71c9727b5b45b1dbd56441fd7bff 100644 (file)
@@ -42,7 +42,7 @@ Remove this patch if these symbols are backported.
  {
 --- a/drivers/net/wireless/Makefile
 +++ b/drivers/net/wireless/Makefile
-@@ -29,7 +29,7 @@ obj-$(CONFIG_RTL8187)                += rtl818x/
+@@ -30,7 +30,7 @@ obj-$(CONFIG_RTL8192CE)              += rtlwifi/
  obj-$(CONFIG_PCMCIA_RAYCS)    += ray_cs.o
  obj-$(CONFIG_PCMCIA_WL3501)   += wl3501_cs.o
  
index 717bec389ca49dab703919b167bea5300c06a8fb..369bb2f7de3f97740fd2238e657d8718b271b07b 100644 (file)
@@ -34,7 +34,7 @@ not be backported easily with defines in the compat module.
        }
 --- a/drivers/net/wireless/rt2x00/rt2x00.h
 +++ b/drivers/net/wireless/rt2x00/rt2x00.h
-@@ -902,7 +902,11 @@ struct rt2x00_dev {
+@@ -908,7 +908,11 @@ struct rt2x00_dev {
        /*
         * FIFO for storing tx status reports between isr and tasklet.
         */
@@ -48,7 +48,7 @@ not be backported easily with defines in the compat module.
         * Tasklet for processing tx status reports (rt2800pci).
 --- a/drivers/net/wireless/rt2x00/rt2x00dev.c
 +++ b/drivers/net/wireless/rt2x00/rt2x00dev.c
-@@ -827,10 +827,16 @@ static int rt2x00lib_probe_hw(struct rt2
+@@ -822,10 +822,16 @@ static int rt2x00lib_probe_hw(struct rt2
                 * queues gets reported before we've got a chance to handle
                 * them) 24*4=384 tx status reports need to be cached.
                 */
index a0acde933799b29991ae3ed693bda690da6b6574..d4b9cf54f462125cf273f4af2c49f4c0381e5974 100644 (file)
@@ -96,7 +96,7 @@ queue by using skb_set_queue_mapping(skb, 0) through ieee80211_tx_skb()
  
 --- a/net/mac80211/tx.c
 +++ b/net/mac80211/tx.c
-@@ -1638,6 +1638,10 @@ static void ieee80211_xmit(struct ieee80
+@@ -1642,6 +1642,10 @@ static void ieee80211_xmit(struct ieee80
                                return;
                        }
  
@@ -107,7 +107,7 @@ queue by using skb_set_queue_mapping(skb, 0) through ieee80211_tx_skb()
        ieee80211_set_qos_hdr(local, skb);
        ieee80211_tx(sdata, skb, false);
        rcu_read_unlock();
-@@ -2125,7 +2129,14 @@ void ieee80211_tx_pending(unsigned long
+@@ -2129,7 +2133,14 @@ void ieee80211_tx_pending(unsigned long
  
                if (skb_queue_empty(&local->pending[i]))
                        list_for_each_entry_rcu(sdata, &local->interfaces, list)
index 34964ee30523cb6ea02c26307ce34c7cee205043..178f4c7fb5c52e5966f5834189dbd46610f44dbc 100644 (file)
@@ -23,7 +23,7 @@ compat-wireless.
 
 --- a/net/wireless/util.c
 +++ b/net/wireless/util.c
-@@ -784,7 +784,7 @@ int cfg80211_change_iface(struct cfg8021
+@@ -785,7 +785,7 @@ int cfg80211_change_iface(struct cfg8021
                return -EOPNOTSUPP;
  
        /* if it's part of a bridge, reject changing type to station/ibss */
@@ -34,7 +34,7 @@ compat-wireless.
             ntype == NL80211_IFTYPE_P2P_CLIENT))
 --- a/net/wireless/nl80211.c
 +++ b/net/wireless/nl80211.c
-@@ -1282,7 +1282,7 @@ static int nl80211_valid_4addr(struct cf
+@@ -1354,7 +1354,7 @@ static int nl80211_valid_4addr(struct cf
                               enum nl80211_iftype iftype)
  {
        if (!use_4addr) {
index dd962f97894addec87ba2322955ad51eea97e5df..63f4b95fc13f076d2665a4e8a43b7e94b1f8a02f 100644 (file)
@@ -2,7 +2,7 @@ Backport commit 99b88a0ecbdbc6df03527292571b2b442965814a
 
 --- a/net/mac80211/main.c
 +++ b/net/mac80211/main.c
-@@ -758,7 +758,11 @@ int ieee80211_register_hw(struct ieee802
+@@ -765,7 +765,11 @@ int ieee80211_register_hw(struct ieee802
                hw->queues = IEEE80211_MAX_QUEUES;
  
        local->workqueue =
@@ -14,7 +14,7 @@ Backport commit 99b88a0ecbdbc6df03527292571b2b442965814a
        if (!local->workqueue) {
                result = -ENOMEM;
                goto fail_workqueue;
-@@ -972,6 +976,10 @@ static void __exit ieee80211_exit(void)
+@@ -979,6 +983,10 @@ static void __exit ieee80211_exit(void)
        rc80211_minstrel_ht_exit();
        rc80211_minstrel_exit();