projects
/
openwrt
/
staging
/
hauke.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
a99b036
)
imagebuilder: use file_copy to deploy files/ in the image generation phase
author
Jo-Philipp Wich
<jow@openwrt.org>
Sun, 2 Dec 2012 12:20:43 +0000
(12:20 +0000)
committer
Jo-Philipp Wich
<jow@openwrt.org>
Sun, 2 Dec 2012 12:20:43 +0000
(12:20 +0000)
SVN-Revision: 34439
target/imagebuilder/files/Makefile
patch
|
blob
|
history
diff --git
a/target/imagebuilder/files/Makefile
b/target/imagebuilder/files/Makefile
index 4d0f1fe1159124c44266579ba5dc590a846e9216..ecaf5ccda32f2b8cc5fa4ed6142be7813927f548 100644
(file)
--- a/
target/imagebuilder/files/Makefile
+++ b/
target/imagebuilder/files/Makefile
@@
-134,15
+134,7
@@
package_install: FORCE
copy_files: FORCE
@echo
@echo Copying extra files
- @( cd $(USER_FILES); find -type f ) | \
- ( cd $(TARGET_DIR); while :; do \
- read FILE; \
- [ -z "$$FILE" ] && break; \
- [ -L "$$FILE" ] || continue; \
- echo "Removing symlink $(TARGET_DIR)/$$FILE"; \
- rm -f "$$FILE"; \
- done; )
- $(CP) $(USER_FILES)/* $(TARGET_DIR)/
+ @$(call file_copy,$(USER_FILES)/*,$(TARGET_DIR)/)
package_postinst: FORCE
@echo