Move compat-wireless specific changes to 98-add-compat-wireless.patch
authorLuis R. Rodriguez <lrodriguez@atheros.com>
Tue, 4 Aug 2009 20:40:09 +0000 (13:40 -0700)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Tue, 4 Aug 2009 20:40:09 +0000 (13:40 -0700)
Changes which add support for compat.h and compat-2.6.*
are put into its own patch file. We use 98 as its the
second to last expect patch. The 99 patch will be
the one that deals with the Makefiles to only enable
the modules we want to compile.

Signed-off-by: Luis R. Rodriguez <lrodriguez@atheros.com>
compat/compat.diff
compat/diffs/98-add-compat-wireless.patch [new file with mode: 0644]

index 65ebc4e0ec8359622bcee25b23208f4ed5c1b746..9b0ac408bb932388878c4d3f3de9858d73427008 100644 (file)
 -obj-$(CONFIG_USB_NET_INT51X1) += int51x1.o
 -obj-$(CONFIG_USB_CDC_PHONET)  += cdc-phonet.o
  
---- a/net/wireless/Makefile
-+++ b/net/wireless/Makefile
-@@ -10,3 +10,11 @@ cfg80211-$(CONFIG_CFG80211_DEBUGFS) += debugfs.o
- cfg80211-$(CONFIG_WIRELESS_EXT) += wext-compat.o wext-sme.o
- ccflags-y += -D__CHECK_ENDIAN__
-+# Compat-wireless kernel compatibility code
-+cfg80211-y += compat-2.6.27.o
-+cfg80211-y += compat-2.6.28.o
-+cfg80211-y += compat-2.6.29.o
-+cfg80211-y += compat-2.6.30.o
-+cfg80211-y += compat-2.6.31.o
-+cfg80211-y += compat-2.6.32.o
-+
---- a/include/net/cfg80211.h
-+++ b/include/net/cfg80211.h
-@@ -23,6 +23,7 @@
- /* remove once we remove the wext stuff */
- #include <net/iw_handler.h>
- #include <linux/wireless.h>
-+#include <net/compat.h>
- /*
 --- a/net/mac80211/rate.c
 +++ b/net/mac80211/rate.c
 @@ -22,7 +22,7 @@ struct rate_control_alg {
diff --git a/compat/diffs/98-add-compat-wireless.patch b/compat/diffs/98-add-compat-wireless.patch
new file mode 100644 (file)
index 0000000..7309fcf
--- /dev/null
@@ -0,0 +1,24 @@
+--- a/net/wireless/Makefile
++++ b/net/wireless/Makefile
+@@ -10,3 +10,11 @@ cfg80211-$(CONFIG_CFG80211_DEBUGFS) += debugfs.o
+ cfg80211-$(CONFIG_WIRELESS_EXT) += wext-compat.o wext-sme.o
+ ccflags-y += -D__CHECK_ENDIAN__
++# Compat-wireless kernel compatibility code
++cfg80211-y += compat-2.6.27.o
++cfg80211-y += compat-2.6.28.o
++cfg80211-y += compat-2.6.29.o
++cfg80211-y += compat-2.6.30.o
++cfg80211-y += compat-2.6.31.o
++cfg80211-y += compat-2.6.32.o
++
+--- a/include/net/cfg80211.h
++++ b/include/net/cfg80211.h
+@@ -23,6 +23,7 @@
+ /* remove once we remove the wext stuff */
+ #include <net/iw_handler.h>
+ #include <linux/wireless.h>
++#include <net/compat.h>
+ /*