tools/coreutils: remove 64-bit time disable flag
authorMichael Pratt <mcpratt@pm.me>
Tue, 25 Jun 2024 06:30:22 +0000 (02:30 -0400)
committerRobert Marko <robimarko@gmail.com>
Thu, 27 Jun 2024 07:31:53 +0000 (09:31 +0200)
This was added to support building coreutils on host systems
that still only have 32-bit time support.

Because other tools now also require the flag for building
with 32-bit time when support for 64-bit time is not present,
this flag is now added to all host builds
on a variable basis using the same test before building,
so it can now be removed from specific tools.

Signed-off-by: Michael Pratt <mcpratt@pm.me>
Link: https://github.com/openwrt/openwrt/pull/15799
Signed-off-by: Robert Marko <robimarko@gmail.com>
tools/coreutils/Makefile

index 5ef780d7d2f8efa972d6ed9cef8b56d0683fbbfb..73b95912ee140ba1585db9fb391e7c0bd0bc9f6c 100644 (file)
@@ -29,7 +29,6 @@ HOST_GNULIB_SKIP := \
        lib/locale.in.h
 
 HOST_CONFIGURE_ARGS += \
-       --disable-year2038 \
         --enable-install-program=$(subst $(space),$(comma),$(strip $(PKG_PROGRAMS)))
 
 HOST_MAKE_FLAGS += \