projects
/
openwrt
/
staging
/
lynxis.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
bc59e3d
)
gcc: compile libgcc and libstdc++ with -O2 instead of -Os on power pc to avoid genera...
author
Felix Fietkau
<nbd@openwrt.org>
Tue, 27 Oct 2009 01:11:35 +0000
(
01:11
+0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Tue, 27 Oct 2009 01:11:35 +0000
(
01:11
+0000)
SVN-Revision: 18177
toolchain/gcc/Makefile
patch
|
blob
|
history
diff --git
a/toolchain/gcc/Makefile
b/toolchain/gcc/Makefile
index 3b31127b4ae6db6815fc573bc2298de964ba76c1..77243c5fa4bd2c45853a5bee0278b2a5062ed19b 100644
(file)
--- a/
toolchain/gcc/Makefile
+++ b/
toolchain/gcc/Makefile
@@
-151,6
+151,10
@@
GCC_CONFIGURE_STAGE2:= \
--disable-tls \
--with-slibdir=$(TOOLCHAIN_DIR)/lib \
+ifdef CONFIG_powerpc
+ TARGET_CFLAGS := $(patsubst -Os,-O2,$(TARGET_CFLAGS))
+endif
+
GCC_MAKE:= \
export SHELL="$(BASH)"; \
$(MAKE) \