#
-# Copyright (C) 2007-2011 OpenWrt.org
+# Copyright (C) 2007-2013 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
include $(TOPDIR)/rules.mk
PKG_NAME:=libtorrent
-PKG_VERSION:=0.12.6
-PKG_RELEASE:=1
+PKG_VERSION:=0.13.3-git
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://libtorrent.rakshasa.no/downloads
-PKG_MD5SUM:=037499ed708aaf72988cee60e5a8d96b
+PKG_RELEASE=$(PKG_SOURCE_VERSION)-1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/rakshasa/libtorrent.git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=6fb96e38f166a1189c1b9af2a6e95bf569a81d4b
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_FIXUP:=autoreconf
PKG_BUILD_PARALLEL:=1
TITLE:=Rakshasa's BitTorrent library
URL:=http://libtorrent.rakshasa.no/
DEPENDS:=+libopenssl +libsigcxx
- MAINTAINER:=Luka Perkov <openwrt@lukaperkov.net>
endef
define Package/libtorrent/description
official client.
endef
-TARGET_CPPFLAGS += -fno-strict-aliasing -fno-inline
TARGET_LDFLAGS += $(LIBGCC_S)
CONFIGURE_ARGS+= \
--enable-static \
--enable-aligned \
--disable-debug \
- --enable-openssl \
+ --enable-openssl
define Build/Configure
( cd $(PKG_BUILD_DIR); ./autogen.sh );
+++ /dev/null
---- a/src/data/memory_chunk.cc
-+++ b/src/data/memory_chunk.cc
-@@ -71,7 +71,7 @@ MemoryChunk::MemoryChunk(char* ptr, char
- if (page_align() >= m_pagesize)
- throw internal_error("MemoryChunk::MemoryChunk(...) received an page alignment >= page size");
-
-- if ((ptrdiff_t)ptr % m_pagesize)
-+ if ((std::ptrdiff_t)ptr % m_pagesize)
- throw internal_error("MemoryChunk::MemoryChunk(...) is not aligned to a page");
- }
-
---- a/src/torrent/data/block.h
-+++ b/src/torrent/data/block.h
-@@ -40,6 +40,7 @@
- #include <vector>
- #include <torrent/common.h>
- #include <torrent/data/block_transfer.h>
-+#include <cstdlib>
-
- namespace torrent {
-
---- a/src/torrent/data/block_transfer.h
-+++ b/src/torrent/data/block_transfer.h
-@@ -39,6 +39,7 @@
-
- #include <torrent/common.h>
- #include <torrent/data/piece.h>
-+#include <cstdlib>
-
- namespace torrent {
-
+--- a/configure.ac
++++ b/configure.ac
+@@ -19,7 +19,6 @@ AC_SUBST(LIBTORRENT_INTERFACE_VERSION_NO
+
+ AM_INIT_AUTOMAKE
+ AC_CONFIG_HEADERS(config.h)
+-AM_PATH_CPPUNIT(1.9.6)
+
+ AC_PROG_CXX
+
--- a/scripts/checks.m4
+++ b/scripts/checks.m4
@@ -96,7 +96,7 @@ AC_DEFUN([TORRENT_CHECK_KQUEUE], [
AC_DEFUN([TORRENT_CHECK_KQUEUE_SOCKET_ONLY], [
AC_MSG_CHECKING(whether kqueue supports pipes and ptys)
-- AC_RUN_IFELSE(
-+ AC_LINK_IFELSE(
- [[#include <fcntl.h>
+- AC_RUN_IFELSE([AC_LANG_SOURCE([
++ AC_LINK_IFELSE([AC_LANG_SOURCE([
+ #include <fcntl.h>
#include <stdlib.h>
#include <unistd.h>
--- a/scripts/common.m4
+++ b/scripts/common.m4
-@@ -184,7 +184,7 @@ AC_DEFUN([TORRENT_CHECK_MADVISE], [
+@@ -223,7 +223,7 @@ dnl Need to fix this so that it uses t
AC_DEFUN([TORRENT_CHECK_EXECINFO], [
AC_MSG_CHECKING(for execinfo.h)
-- AC_RUN_IFELSE(
-+ AC_LINK_IFELSE(
- [[#include <execinfo.h>
+- AC_RUN_IFELSE([AC_LANG_SOURCE([
++ AC_LINK_IFELSE([AC_LANG_SOURCE([
+ #include <execinfo.h>
int main() { backtrace((void**)0, 0); backtrace_symbols((char**)0, 0); return 0;}
- ]],
-@@ -199,7 +199,7 @@ AC_DEFUN([TORRENT_CHECK_EXECINFO], [
+ ])],
+@@ -238,7 +238,7 @@ AC_DEFUN([TORRENT_CHECK_EXECINFO], [
AC_DEFUN([TORRENT_CHECK_ALIGNED], [
AC_MSG_CHECKING(the byte alignment)
-- AC_RUN_IFELSE(
-+ AC_LINK_IFELSE(
- [[#include <inttypes.h>
+- AC_RUN_IFELSE([AC_LANG_SOURCE([
++ AC_LINK_IFELSE([AC_LANG_SOURCE([
+ #include <inttypes.h>
int main() {
- char buf[8] = { 0, 0, 0, 0, 1, 0, 0, 0 };
+ char buf@<:@8@:>@ = { 0, 0, 0, 0, 1, 0, 0, 0 };