backports: add intel_ips support
authorLuis R. Rodriguez <mcgrof@do-not-panic.com>
Sat, 13 Apr 2013 14:13:44 +0000 (07:13 -0700)
committerJohannes Berg <johannes.berg@intel.com>
Sat, 13 Apr 2013 21:03:19 +0000 (23:03 +0200)
1   2.6.24              [  OK  ]
2   2.6.25              [  OK  ]
3   2.6.26              [  OK  ]
4   2.6.27              [  OK  ]
5   2.6.28              [  OK  ]
6   2.6.29              [  OK  ]
7   2.6.30              [  OK  ]
8   2.6.31              [  OK  ]
9   2.6.32              [  OK  ]
10  2.6.33              [  OK  ]
11  2.6.34              [  OK  ]
12  2.6.35              [  OK  ]
13  2.6.36              [  OK  ]
14  2.6.37              [  OK  ]
15  2.6.38              [  OK  ]
16  2.6.39              [  OK  ]
17  3.0.65              [  OK  ]
18  3.1.10              [  OK  ]
19  3.2.38              [  OK  ]
20  3.3.8               [  OK  ]
21  3.4.32              [  OK  ]
22  3.5.7               [  OK  ]
23  3.6.11              [  OK  ]
24  3.7.9               [  OK  ]
25  3.8.0               [  OK  ]
26  3.9-rc1             [  OK  ]

real    39m35.615s
user    1068m47.428s
sys     155m55.657s

Signed-off-by: Luis R. Rodriguez <mcgrof@do-not-panic.com>
Signed-off-by: Johannes Berg <johannes.berg@intel.com>
backport/Kconfig
backport/Makefile.kernel
copy-list
dependencies

index 2c75cd8fc294a203b0a46614c399d18332c3ea88..3103f10639153b1f09b25ab4b3df8360c5f1db4a 100644 (file)
@@ -41,3 +41,5 @@ source net/nfc/Kconfig
 
 source drivers/regulator/Kconfig
 source drivers/media/Kconfig
+
+source drivers/platform/x86/Kconfig
index 27b44daf1a9635d47c5bdb64c7cf6c4b9dce50fe..096e80c2cda62e04183a72b840b5c59e42a55689 100644 (file)
@@ -33,3 +33,4 @@ obj-$(CPTCFG_NFC) += net/nfc/
 obj-$(CPTCFG_NFC) += drivers/nfc/
 obj-$(CPTCFG_REGULATOR) += drivers/regulator/
 obj-$(CPTCFG_MEDIA_SUPPORT) += drivers/media/
+obj-$(CPTCFG_INTEL_IPS) += drivers/platform/x86/
index 0c25be504a09bf1db50be2db5d0771e5213eade4..b49901d6eb9b1fa310d3b6b4b5517a80f05ef725 100644 (file)
--- a/copy-list
+++ b/copy-list
@@ -185,3 +185,10 @@ include/uapi/linux/v4l2-subdev.h
 include/uapi/linux/videodev2.h
 
 drivers/media/
+
+# Platform
+drivers/platform/x86/Kconfig
+drivers/platform/x86/Makefile
+drivers/platform/x86/intel_ips.c
+drivers/platform/x86/intel_ips.h
+include/asm-generic/io-64-nonatomic-lo-hi.h
index 0658289cd94697a0bf6ba0055432cb711e37d50b..f939b904efa17c612ea20c3726bc11ee18819570 100644 (file)
@@ -157,3 +157,5 @@ BT_HIDP 2.6.33
 # NFC core needs PF_NFC defined in socket.h which was
 # only introduced in kernel 3.1
 NFC 3.1
+
+INTEL_IPS 3.2