projects
/
openwrt
/
staging
/
rmilecki.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
96cc417
)
add menuconfig option to enable log files during build process
author
John Crispin
<john@openwrt.org>
Sun, 3 Jul 2011 17:37:31 +0000
(17:37 +0000)
committer
John Crispin
<john@openwrt.org>
Sun, 3 Jul 2011 17:37:31 +0000
(17:37 +0000)
SVN-Revision: 27403
Config.in
patch
|
blob
|
history
rules.mk
patch
|
blob
|
history
diff --git
a/Config.in
b/Config.in
index 61d87a0a1cebda91e062a9265c26789a27c6f0b6..f36221cee660a8aa9aec3e0e6a9751b34c3ab7c7 100644
(file)
--- a/
Config.in
+++ b/
Config.in
@@
-425,6
+425,11
@@
menuconfig DEVEL
In this instance, the --refererence option of git clone will
be used thus creating a quick local clone of your repo.
+ config BUILD_LOG
+ bool "Enable log files during build process" if DEVEL
+ help
+ If enabled log files will be written to the ./log directory
+
menuconfig TARGET_OPTIONS
bool "Target Options" if DEVEL
diff --git
a/rules.mk
b/rules.mk
index 7be2d6195d99afc1ad96b1ecc39972dbd1b8ad17..874066e3785ffabce2f19543c3ecc9ce842cb88d 100644
(file)
--- a/
rules.mk
+++ b/
rules.mk
@@
-239,6
+239,10
@@
else
TAR_OPTIONS:=-xf -
endif
+ifeq ($(CONFIG_BUILD_LOG),y)
+ BUILD_LOG:=1
+endif
+
define shvar
V_$(subst .,_,$(subst -,_,$(subst /,_,$(1))))
endef