fix typo in netfilter config (proper fix for iptables)
authorNicolas Thill <nico@openwrt.org>
Sat, 12 Nov 2005 11:45:20 +0000 (11:45 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 12 Nov 2005 11:45:20 +0000 (11:45 +0000)
SVN-Revision: 2447

openwrt/package/iptables/Makefile
openwrt/target/linux/netfilter.mk

index 94e9df8c5b9a070e864d9f1a222d2f440e1c9480..f6b61a1b66faec320447e9f1a5216dfebb73e11e 100644 (file)
@@ -75,7 +75,7 @@ $(IPKG_IPTABLES):
        cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/iptables $(IDIR_IPTABLES)/usr/sbin/
        install -d -m0755 $(IDIR_IPTABLES)/usr/lib/iptables
        (cd $(PKG_INSTALL_DIR)/usr/lib/iptables ; \
-               cp -fpR $(patsubst %,lib%.so,$(IPKG_IPTABLES-y) ipt_standard) $(IDIR_IPTABLES)/usr/lib/iptables/ \
+               cp -fpR $(patsubst %,lib%.so,$(IPKG_IPTABLES-y)) $(IDIR_IPTABLES)/usr/lib/iptables/ \
        )
        $(RSTRIP) $(IDIR_IPTABLES)
        $(IPKG_BUILD) $(IDIR_IPTABLES) $(PACKAGE_DIR)
index a9aae1a87c8b72e1ea1f617c807d2bbb949c7811..5d4107d87c184934ac85a90e7401946d97447dab 100644 (file)
@@ -71,7 +71,7 @@ IPKG_KMOD_IPT_ULOG-$(CONFIG_IP_NF_TARGET_ULOG) += ipt_ULOG
 #
 
 IPKG_IPTABLES-y := ipt_standard
-IPKG_IPTABLES-y := ipt_icmp ipt_tcp ipt_udp
+IPKG_IPTABLES-y += ipt_icmp ipt_tcp ipt_udp
 
 IPKG_IPTABLES_MOD_CONNTRACK-m :=
 IPKG_IPTABLES_MOD_CONNTRACK-$(CONFIG_IP_NF_MATCH_CONNMARK) += ipt_connmark