sdk: fix APK key creation
authorPaul Spooren <mail@aparcar.org>
Thu, 8 Aug 2024 15:31:18 +0000 (17:31 +0200)
committerPaul Spooren <mail@aparcar.org>
Thu, 8 Aug 2024 23:47:05 +0000 (01:47 +0200)
The keys are created differently compared to the old OPKG keys. Instead
of being part of base-files/configure, they are created as a Makefile
requirement of `package/compile`, which is a cleaner solution.

This requirement would only be added to non SDK environments, however
APK always requires keys to be available. Add an `else` case for the SDK
and create keys.

Signed-off-by: Paul Spooren <mail@aparcar.org>
package/Makefile

index 9e3bb52b657800d78832202f57b79f8daf0e5ee0..9de36b13c965a3998a315d9228919d68995c56d3 100644 (file)
@@ -85,6 +85,10 @@ ifneq ($(CONFIG_USE_APK),)
 else
   $(curdir)/compile: $(curdir)/system/opkg/host/compile
 endif
+else
+ifneq ($(CONFIG_USE_APK),)
+  $(curdir)/compile: $(BUILD_KEY_APK_SEC) $(BUILD_KEY_APK_PUB)
+endif
 endif
 
 $(curdir)/install: $(TMP_DIR)/.build $(curdir)/merge $(curdir)/merge-index