Move down bluetooth config.mk options
authorLuis R. Rodriguez <lrodriguez@atheros.com>
Tue, 12 Jan 2010 23:35:07 +0000 (15:35 -0800)
committerLuis R. Rodriguez <lrodriguez@atheros.com>
Tue, 12 Jan 2010 23:38:16 +0000 (15:38 -0800)
We'll make some more changes to this later. I move this as a
separate patch to make the other changes more easier to review.

Signed-off-by: Luis R. Rodriguez <lrodriguez@atheros.com>
config.mk
enable-older-kernels/enable-2.6.21.patch
enable-older-kernels/enable-2.6.22.patch
enable-older-kernels/enable-2.6.23.patch
enable-older-kernels/enable-2.6.24.patch

index 3a13e8a2b497604a3494f350131a2dc21e15cc8c..8f553c76f45b0214e4cfd9d13f395c6d25168a3d 100644 (file)
--- a/config.mk
+++ b/config.mk
@@ -15,31 +15,6 @@ else
 include $(KLIB_BUILD)/.config
 endif
 
-# These both are needed by compat-wireless || compat-bluetooth so enable them
- CONFIG_COMPAT_RFKILL=y
-
-ifeq ($(CONFIG_MAC80211),y)
-$(error "ERROR: you have MAC80211 compiled into the kernel, CONFIG_MAC80211=y, as such you cannot replace its mac80211 driver. You need this set to CONFIG_MAC80211=m. If you are using Fedora upgrade your kernel as later version should this set as modular. For further information on Fedora see https://bugzilla.redhat.com/show_bug.cgi?id=470143. If you are using your own kernel recompile it and make mac80211 modular")
-else
- CONFIG_COMPAT_WIRELESS=y
- CONFIG_COMPAT_WIRELESS_MODULES=m
- CONFIG_COMPAT_VAR_MODULES=m
-# We could technically separate these but not yet, we only have b44
-# Note that we don't intend on backporting network drivers that
-# use Multiqueue as that was a pain to backport to kernels older than
-# 2.6.27. But -- we could just disable those drivers from kernels
-# older than 2.6.27
- CONFIG_COMPAT_NETWORK_MODULES=m
- CONFIG_COMPAT_NET_USB_MODULES=m
-endif
-
-ifeq ($(CONFIG_BT),y)
-# we'll ignore compiling bluetooth
-else
-CONFIG_COMPAT_BLUETOOTH=y
-CONFIG_COMPAT_BLUETOOTH_MODULES=m
-endif
-
 # We will warn when you don't have MQ support or NET_SCHED enabled.
 #
 # We could consider just quiting if MQ and NET_SCHED is disabled
@@ -97,6 +72,32 @@ endif
 endif # build check
 endif # kernel Makefile check
 
+# These both are needed by compat-wireless || compat-bluetooth so enable them
+ CONFIG_COMPAT_RFKILL=y
+
+ifeq ($(CONFIG_MAC80211),y)
+$(error "ERROR: you have MAC80211 compiled into the kernel, CONFIG_MAC80211=y, as such you cannot replace its mac80211 driver. You need this set to CONFIG_MAC80211=m. If you are using Fedora upgrade your kernel as later version should this set as modular. For further information on Fedora see https://bugzilla.redhat.com/show_bug.cgi?id=470143. If you are using your own kernel recompile it and make mac80211 modular")
+else
+ CONFIG_COMPAT_WIRELESS=y
+ CONFIG_COMPAT_WIRELESS_MODULES=m
+ CONFIG_COMPAT_VAR_MODULES=m
+# We could technically separate these but not yet, we only have b44
+# Note that we don't intend on backporting network drivers that
+# use Multiqueue as that was a pain to backport to kernels older than
+# 2.6.27. But -- we could just disable those drivers from kernels
+# older than 2.6.27
+ CONFIG_COMPAT_NETWORK_MODULES=m
+ CONFIG_COMPAT_NET_USB_MODULES=m
+endif
+
+ifeq ($(CONFIG_BT),y)
+# we'll ignore compiling bluetooth
+else
+CONFIG_COMPAT_BLUETOOTH=y
+CONFIG_COMPAT_BLUETOOTH_MODULES=m
+endif
+
+
 # Wireless subsystem stuff
 CONFIG_MAC80211=m
 
index 413ad10a3533d5549d50599071b6b6ec2061feef..db88433b707b16ccff7d8a0facf349b1476fc2f5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/config.mk        2010-01-11 10:27:53.000000000 -0800
 +++ b/config.mk        2010-01-11 10:32:49.000000000 -0800
-@@ -51,8 +51,8 @@
+@@ -26,8 +26,8 @@
  COMPAT_VERSIONS := $(shell I=$(COMPAT_LATEST_VERSION); while [ "$$I" -gt $(KERNEL_SUBLEVEL) ]; do echo $$I; I=$$(($$I - 1)); done)
  $(foreach ver,$(COMPAT_VERSIONS),$(eval CONFIG_COMPAT_KERNEL_$(ver)=y))
  
index 0c6643b871aea16b727cc707742cebfc6c64dfe5..e26053eda141485af761af71956ad7103a9ded58 100644 (file)
@@ -1,6 +1,6 @@
 --- a/config.mk        2010-01-11 10:27:53.000000000 -0800
 +++ b/config.mk        2010-01-11 10:32:49.000000000 -0800
-@@ -51,8 +51,8 @@
+@@ -26,8 +26,8 @@
  COMPAT_VERSIONS := $(shell I=$(COMPAT_LATEST_VERSION); while [ "$$I" -gt $(KERNEL_SUBLEVEL) ]; do echo $$I; I=$$(($$I - 1)); done)
  $(foreach ver,$(COMPAT_VERSIONS),$(eval CONFIG_COMPAT_KERNEL_$(ver)=y))
  
index 30ce9008ee26a8a0b0f5a1c29441d7e331498ad3..8fe347ef4842b815938ab2bf1217133022295cef 100644 (file)
@@ -1,6 +1,6 @@
 --- a/config.mk        2010-01-11 10:27:53.000000000 -0800
 +++ b/config.mk        2010-01-11 10:32:49.000000000 -0800
-@@ -51,8 +51,8 @@
+@@ -26,8 +26,8 @@
  COMPAT_VERSIONS := $(shell I=$(COMPAT_LATEST_VERSION); while [ "$$I" -gt $(KERNEL_SUBLEVEL) ]; do echo $$I; I=$$(($$I - 1)); done)
  $(foreach ver,$(COMPAT_VERSIONS),$(eval CONFIG_COMPAT_KERNEL_$(ver)=y))
  
index 9e71d807d922c64eb33ba7a6d04c72cf348ac097..15fc21d95711c29307be8d6015f50b3c500cf605 100644 (file)
@@ -1,6 +1,6 @@
 --- a/config.mk        2010-01-11 10:27:53.000000000 -0800
 +++ b/config.mk        2010-01-11 10:32:49.000000000 -0800
-@@ -51,8 +51,8 @@
+@@ -26,8 +26,8 @@
  COMPAT_VERSIONS := $(shell I=$(COMPAT_LATEST_VERSION); while [ "$$I" -gt $(KERNEL_SUBLEVEL) ]; do echo $$I; I=$$(($$I - 1)); done)
  $(foreach ver,$(COMPAT_VERSIONS),$(eval CONFIG_COMPAT_KERNEL_$(ver)=y))