util-linux: update to v2.41
authorThomas Weißschuh <thomas@t-8ch.de>
Mon, 14 Apr 2025 21:39:43 +0000 (23:39 +0200)
committerRobert Marko <robimarko@gmail.com>
Fri, 18 Apr 2025 15:23:42 +0000 (17:23 +0200)
Release Notes:
https://www.kernel.org/pub/linux/utils/util-linux/v2.41/v2.41-ReleaseNotes

New:
0001-meson-add-feature-for-translated-documentation.patch
0001-meson-remove-tinfo-dependency-from-more.patch

Signed-off-by: Thomas Weißschuh <thomas@t-8ch.de>
Link: https://github.com/openwrt/openwrt/pull/18493
Signed-off-by: Robert Marko <robimarko@gmail.com>
package/utils/util-linux/Makefile
package/utils/util-linux/patches/0001-meson-add-feature-for-translated-documentation.patch [new file with mode: 0644]
package/utils/util-linux/patches/0001-meson-remove-tinfo-dependency-from-more.patch [new file with mode: 0644]

index 83f3a8c8424d4ee3756ab7915e0bf892de636b09..9caf587d582376d948ebe998bb9a9e56c15c58d5 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=util-linux
-PKG_VERSION:=2.40.2
+PKG_VERSION:=2.41
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.40
-PKG_HASH:=d78b37a66f5922d70edf3bdfb01a6b33d34ed3c3cafd6628203b2a2b67c8e8b3
+PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.41
+PKG_HASH:=81ee93b3cfdfeb7d7c4090cedeba1d7bbce9141fd0b501b686b3fe475ddca4c6
 PKG_CPE_ID:=cpe:/a:kernel:util-linux
 
 PKG_LICENSE:=GPL-2.0-only
@@ -581,6 +581,7 @@ MESON_ARGS += \
        -Dlibuser=disabled \
        -Duse-tty-group=false \
        -Duse-tls=false \
+       -Dtranslate-docs=disabled \
        -Dbuild-python=disabled \
        -Dbuild-zramctl=disabled \
        -Dbuild-fsck=disabled \
@@ -594,7 +595,6 @@ MESON_ARGS += \
        -Dbuild-fdformat=disabled \
        -Dbuild-lslogins=disabled \
        -Dbuild-wdctl=disabled \
-       -Dbuild-cal=disabled \
        -Dbuild-switch_root=disabled \
        -Dbuild-pivot_root=disabled \
        -Dbuild-lsmem=disabled \
diff --git a/package/utils/util-linux/patches/0001-meson-add-feature-for-translated-documentation.patch b/package/utils/util-linux/patches/0001-meson-add-feature-for-translated-documentation.patch
new file mode 100644 (file)
index 0000000..8f187c4
--- /dev/null
@@ -0,0 +1,38 @@
+From cd5038306e6815592fafbd06d406f45af2df3fcc Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Thomas=20Wei=C3=9Fschuh?= <thomas@t-8ch.de>
+Date: Mon, 14 Apr 2025 23:32:36 +0200
+Subject: [PATCH] meson: add feature for translated documentation
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Translating the documentation is slow.
+Add a feature which can be used to disable this step.
+
+Signed-off-by: Thomas Weißschuh <thomas@t-8ch.de>
+---
+ meson_options.txt  | 2 ++
+ po-man/meson.build | 2 +-
+ 2 files changed, 3 insertions(+), 1 deletion(-)
+
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -25,6 +25,8 @@ option('sysvinit',    type : 'feature',
+ option('btrfs',       type : 'feature')
+ option('widechar',    type : 'feature',
+        description : 'compile with wide character support')
++option('translate-docs', type : 'feature',
++       description : 'translate documentation')
+ # enable building of various programs and features ("build-" prefix)
+--- a/po-man/meson.build
++++ b/po-man/meson.build
+@@ -1,6 +1,6 @@
+ po4a = find_program('po4a', required : false)
+-if not (asciidoctor.found() and po4a.found())
++if not get_option('translate-docs').require(asciidoctor.found()).require(po4a.found()).allowed()
+   subdir_done()
+ endif
diff --git a/package/utils/util-linux/patches/0001-meson-remove-tinfo-dependency-from-more.patch b/package/utils/util-linux/patches/0001-meson-remove-tinfo-dependency-from-more.patch
new file mode 100644 (file)
index 0000000..3d195c0
--- /dev/null
@@ -0,0 +1,38 @@
+From 363e48da01956321fb9337c59d78865c97c711a2 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Thomas=20Wei=C3=9Fschuh?= <thomas@t-8ch.de>
+Date: Mon, 14 Apr 2025 23:19:06 +0200
+Subject: [PATCH] meson: remove tinfo dependency from 'more'
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+The more utility does not need libtinfo and it is not
+specified in autotools either.
+
+Signed-off-by: Thomas Weißschuh <thomas@t-8ch.de>
+---
+ meson.build | 6 ++----
+ 1 file changed, 2 insertions(+), 4 deletions(-)
+
+--- a/meson.build
++++ b/meson.build
+@@ -1387,8 +1387,7 @@ exe = executable(
+   more_sources,
+   link_with : [lib_common],
+   include_directories : includes,
+-  dependencies : [lib_tinfo,
+-                  curses_libs,
++  dependencies : [curses_libs,
+                 lib_magic],
+   install : opt,
+   build_by_default : opt)
+@@ -1398,8 +1397,7 @@ exe2 = executable(
+   link_with : [lib_common],
+   include_directories : includes,
+   c_args : '-DTEST_PROGRAM',
+-  dependencies : [lib_tinfo,
+-                  curses_libs,
++  dependencies : [curses_libs,
+                 lib_magic],
+   build_by_default : opt and program_tests)
+ exes += exe