linux-firmware: add LICENSE_FILES and LICENSE file handling
authorFlorian Eckert <fe@dev.tdt.de>
Wed, 13 Mar 2024 12:21:34 +0000 (13:21 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 10 Jul 2024 21:07:36 +0000 (23:07 +0200)
The firmware blobs have all different licenses from the different
manufacturers of the binary blobs. This information is contained in the
upstream 'linux-firmware' repositroy.

This commit extends the package handling so that this information can be
added as an additional argument during packages generation.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
(cherry picked from commit 5c14de1d7e715ef882f34925ee6702b847efcbbd)
Link: https://github.com/openwrt/openwrt/pull/15918
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/firmware/linux-firmware/Makefile

index ef6cd075de45480b17c4786220152626b498d36a..361d8b55eecefb088cad60ade25fdcbdefd37aa9 100644 (file)
@@ -30,6 +30,8 @@ define Package/firmware-default
   URL:=http://git.kernel.org/cgit/linux/kernel/git/firmware/linux-firmware.git
   TITLE:=$(1)
   DEPENDS:=$(2)
+  LICENSE_FILES:=$(3)
+  LICENSE:=$(4)
 endef
 
 define Build/Compile