projects
/
openwrt
/
staging
/
stintel.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
34f4f4a
)
ensure that profile Makefiles are sourced in alphabetical order Since make 3.82 does...
author
Jo-Philipp Wich
<jow@openwrt.org>
Mon, 23 Apr 2012 16:10:25 +0000
(16:10 +0000)
committer
Jo-Philipp Wich
<jow@openwrt.org>
Mon, 23 Apr 2012 16:10:25 +0000
(16:10 +0000)
SVN-Revision: 31449
include/target.mk
patch
|
blob
|
history
diff --git
a/include/target.mk
b/include/target.mk
index 097b275cf2c9ecb93058482227784762659f61cf..e5166fb784e6e096c3740865805f3ed84ba26a63 100644
(file)
--- a/
include/target.mk
+++ b/
include/target.mk
@@
-84,12
+84,12
@@
endif
ifneq ($(PLATFORM_DIR),$(PLATFORM_SUBDIR))
define IncludeProfiles
- -include $(
PLATFORM_DIR)/profiles/*.mk
- -include $(
PLATFORM_SUBDIR)/profiles/*.mk
+ -include $(
sort $(wildcard $(PLATFORM_DIR)/profiles/*.mk))
+ -include $(
sort $(wildcard $(PLATFORM_SUBDIR)/profiles/*.mk))
endef
else
define IncludeProfiles
- -include $(
PLATFORM_DIR)/profiles/*.mk
+ -include $(
sort $(wildcard $(PLATFORM_DIR)/profiles/*.mk))
endef
endif