ifeq ($(LINUX_VERSION),2.6.36.4)
LINUX_KERNEL_MD5SUM:=c05dd941d0e249695e9f72568888e1bf
endif
-ifeq ($(LINUX_VERSION),2.6.37.1)
- LINUX_KERNEL_MD5SUM:=07d3b1868a67c1a7ddcf1d54444cb5d1
+ifeq ($(LINUX_VERSION),2.6.37.3)
+ LINUX_KERNEL_MD5SUM:=b32fc95037e4e114fcfb33075bb30f46
endif
# disable the md5sum check for unknown kernel versions
BOARDNAME:=TI AR7
FEATURES:=squashfs jffs2 atm
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
include $(INCLUDE_DIR)/target.mk
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
SUBTARGETS:=generic nand
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
include $(INCLUDE_DIR)/target.mk
BOARDNAME:=Atheros AR231x/AR5312
FEATURES:=squashfs jffs2
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
include $(INCLUDE_DIR)/target.mk
FEATURES:=jffs2 usb pci
SUBTARGETS=au1500 au1550
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += wpad-mini yamonenv
FEATURES:=squashfs
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
include $(INCLUDE_DIR)/target.mk
depends on USB
--- a/drivers/usb/host/ehci-hcd.c
+++ b/drivers/usb/host/ehci-hcd.c
-@@ -1216,9 +1216,14 @@ MODULE_LICENSE ("GPL");
+@@ -1229,9 +1229,14 @@ MODULE_LICENSE ("GPL");
#define PLATFORM_DRIVER ehci_octeon_driver
#endif
#error "missing bus glue for ehci-hcd"
#endif
-@@ -1278,10 +1283,20 @@ static int __init ehci_hcd_init(void)
+@@ -1291,10 +1296,20 @@ static int __init ehci_hcd_init(void)
if (retval < 0)
goto clean4;
#endif
clean4:
#endif
#ifdef OF_PLATFORM_DRIVER
-@@ -1312,6 +1327,9 @@ module_init(ehci_hcd_init);
+@@ -1325,6 +1340,9 @@ module_init(ehci_hcd_init);
static void __exit ehci_hcd_cleanup(void)
{
+#endif
--- a/drivers/usb/host/ehci-hcd.c
+++ b/drivers/usb/host/ehci-hcd.c
-@@ -1284,17 +1284,21 @@ static int __init ehci_hcd_init(void)
+@@ -1297,17 +1297,21 @@ static int __init ehci_hcd_init(void)
goto clean4;
#endif
#ifdef XILINX_OF_PLATFORM_DRIVER
of_unregister_platform_driver(&XILINX_OF_PLATFORM_DRIVER);
clean4:
-@@ -1327,9 +1331,11 @@ module_init(ehci_hcd_init);
+@@ -1340,9 +1344,11 @@ module_init(ehci_hcd_init);
static void __exit ehci_hcd_cleanup(void)
{
if (tg3_nvram_read(tp, 0, &magic) != 0)
return -EIO;
-@@ -11169,7 +11230,7 @@ static int tg3_ioctl(struct net_device *
+@@ -11171,7 +11232,7 @@ static int tg3_ioctl(struct net_device *
return -EAGAIN;
spin_lock_bh(&tp->lock);
spin_unlock_bh(&tp->lock);
data->val_out = mii_regval;
-@@ -11185,7 +11246,7 @@ static int tg3_ioctl(struct net_device *
+@@ -11189,7 +11250,7 @@ static int tg3_ioctl(struct net_device *
return -EAGAIN;
spin_lock_bh(&tp->lock);
spin_unlock_bh(&tp->lock);
return err;
-@@ -11830,6 +11891,12 @@ static void __devinit tg3_get_5717_nvram
+@@ -11834,6 +11895,12 @@ static void __devinit tg3_get_5717_nvram
/* Chips other than 5700/5701 use the NVRAM for fetching info. */
static void __devinit tg3_nvram_init(struct tg3 *tp)
{
tw32_f(GRC_EEPROM_ADDR,
(EEPROM_ADDR_FSM_RESET |
(EEPROM_DEFAULT_CLOCK_PERIOD <<
-@@ -12093,6 +12160,9 @@ static int tg3_nvram_write_block(struct
+@@ -12097,6 +12164,9 @@ static int tg3_nvram_write_block(struct
{
int ret;
if (tp->tg3_flags & TG3_FLAG_EEPROM_WRITE_PROT) {
tw32_f(GRC_LOCAL_CTRL, tp->grc_local_ctrl &
~GRC_LCLCTRL_GPIO_OUTPUT1);
-@@ -13518,6 +13588,11 @@ static int __devinit tg3_get_invariants(
+@@ -13522,6 +13592,11 @@ static int __devinit tg3_get_invariants(
GET_ASIC_REV(tp->pci_chip_rev_id) == ASIC_REV_5701)))
tp->tg3_flags |= TG3_FLAG_SRAM_USE_CONFIG;
/* Get eeprom hw config before calling tg3_set_power_state().
* In particular, the TG3_FLG2_IS_NIC flag must be
* determined before calling tg3_set_power_state() so that
-@@ -13916,6 +13991,10 @@ static int __devinit tg3_get_device_addr
+@@ -13920,6 +13995,10 @@ static int __devinit tg3_get_device_addr
}
if (!is_valid_ether_addr(&dev->dev_addr[0])) {
#ifdef CONFIG_SPARC
if (!tg3_get_default_macaddr_sparc(tp))
return 0;
-@@ -14432,6 +14511,7 @@ static char * __devinit tg3_phy_string(s
+@@ -14436,6 +14515,7 @@ static char * __devinit tg3_phy_string(s
case TG3_PHY_ID_BCM5704: return "5704";
case TG3_PHY_ID_BCM5705: return "5705";
case TG3_PHY_ID_BCM5750: return "5750";
case TG3_PHY_ID_BCM5752: return "5752";
case TG3_PHY_ID_BCM5714: return "5714";
case TG3_PHY_ID_BCM5780: return "5780";
-@@ -14643,6 +14723,13 @@ static int __devinit tg3_init_one(struct
+@@ -14647,6 +14727,13 @@ static int __devinit tg3_init_one(struct
tp->msg_enable = tg3_debug;
else
tp->msg_enable = TG3_DEF_MSG_ENABLE;
{PCI_DEVICE(PCI_VENDOR_ID_BROADCOM, PCI_DEVICE_ID_TIGON3_5752)},
--- a/include/linux/pci_ids.h
+++ b/include/linux/pci_ids.h
-@@ -2067,6 +2067,7 @@
+@@ -2068,6 +2068,7 @@
#define PCI_DEVICE_ID_NX2_57711E 0x1650
#define PCI_DEVICE_ID_TIGON3_5705 0x1653
#define PCI_DEVICE_ID_TIGON3_5705_2 0x1654
#define PCI_DEVICE_ID_TIGON3_5721 0x1659
#define PCI_DEVICE_ID_TIGON3_5722 0x165a
#define PCI_DEVICE_ID_TIGON3_5723 0x165b
-@@ -2080,11 +2081,13 @@
+@@ -2081,11 +2082,13 @@
#define PCI_DEVICE_ID_TIGON3_5754M 0x1672
#define PCI_DEVICE_ID_TIGON3_5755M 0x1673
#define PCI_DEVICE_ID_TIGON3_5756 0x1674
bool ssb_is_sprom_available(struct ssb_bus *bus)
--- a/include/linux/ssb/ssb.h
+++ b/include/linux/ssb/ssb.h
-@@ -401,6 +401,7 @@ extern bool ssb_is_sprom_available(struc
+@@ -408,6 +408,7 @@ extern bool ssb_is_sprom_available(struc
/* Set a fallback SPROM.
* See kdoc at the function definition for complete documentation. */
extern int ssb_arch_set_fallback_sprom(const struct ssb_sprom *sprom);
CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -funit-at-a-time
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
include $(INCLUDE_DIR)/target.mk
/* LzmaDecode
--- a/lib/lzma/LzmaDec.c
+++ b/lib/lzma/LzmaDec.c
-@@ -682,7 +682,7 @@ static void LzmaDec_InitRc(CLzmaDec *p,
+@@ -682,7 +682,7 @@ static void LzmaDec_InitRc(CLzmaDec *p,
p->needFlush = 0;
}
{
CLzmaProps propNew;
RINOK(LzmaProps_Decode(&propNew, props, propsSize));
-@@ -944,7 +944,7 @@ SRes LzmaDec_AllocateProbs(CLzmaDec *p,
+@@ -944,7 +944,7 @@ SRes LzmaDec_AllocateProbs(CLzmaDec *p,
return SZ_OK;
}
void MatchFinder_Construct(CMatchFinder *p);
/* Conditions:
-@@ -70,12 +65,6 @@ int MatchFinder_Create(CMatchFinder *p,
+@@ -70,12 +65,6 @@ int MatchFinder_Create(CMatchFinder *p,
UInt32 keepAddBufferBefore, UInt32 matchMaxLen, UInt32 keepAddBufferAfter,
ISzAlloc *alloc);
void MatchFinder_Free(CMatchFinder *p, ISzAlloc *alloc);
-Index: linux-2.6.37/drivers/atm/solos-pci.c
-===================================================================
---- linux-2.6.37.orig/drivers/atm/solos-pci.c 2011-03-05 21:46:26.136023697 +0100
-+++ linux-2.6.37/drivers/atm/solos-pci.c 2011-03-05 21:48:49.046598163 +0100
+--- a/drivers/atm/solos-pci.c
++++ b/drivers/atm/solos-pci.c
@@ -710,8 +710,8 @@ void solos_bh(unsigned long card_arg)
le16_to_cpu(header->vci));
if (!vcc) {
/**
* zap_vma_ptes - remove ptes mapping the vma
-@@ -2614,6 +2615,7 @@ int vmtruncate_range(struct inode *inode
+@@ -2616,6 +2617,7 @@ int vmtruncate_range(struct inode *inode
return 0;
}
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
SUBTARGETS=generic harddisk
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
include $(INCLUDE_DIR)/target.mk
FEATURES:=squashfs jffs2
SUBTARGETS:=falcon xway
-LINUX_VERSION:=2.6.37.2
+LINUX_VERSION:=2.6.37.3
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
SUBTARGETS:=le be
INITRAMFS_EXTRA_FILES:=
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
include $(INCLUDE_DIR)/target.mk
CFLAGS=-Os -pipe -march=armv5t -mtune=xscale -funit-at-a-time
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
include $(INCLUDE_DIR)/target.mk
FEATURES:=squashfs jffs2 fpu
CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -funit-at-a-time
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
include $(INCLUDE_DIR)/target.mk
FEATURES:=ext4 audio
LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
include $(INCLUDE_DIR)/target.mk
FEATURES:=jffs2 targz ubifs audio
SUBTARGETS:=qi_lb60 n516 n526 id800wt
-LINUX_VERSION:=2.6.37.1
+LINUX_VERSION:=2.6.37.3
DEVICE_TYPE=other